1

Hello guys my first post on this forum so please give me feed back if I´m posting in a stupid or complicated way and have patience whit my bad spelling do I´m dyslectic. I made this illustration of my problem that is my IPv6 being forwarder from wlan0 to eth0 and then to my IPv4 ISP instead of going thru my he tunnel. I have tried a lot of different configurations whit out any result so far, maybe some one have some good advise for me.

                    IPv4        IPv4
                           _eth0--------------ISP
    IPv4                  /
My Laptop wlo1 --------- wlan0 router Laptop
    IPv6                         IPv6
                             HE-tunnel----------End point and IPv6 internet

My laptop wlo1: 2001:470:27:46e:3ab2:69d4:8419:325d/64

router Laptop wlan0: fe80::4a5d:60ff:fe9f:25b1/64

router Laptop eth0: fe80::beae:c5ff:fe37:de45/64

router Laptop HE-tunnel: 2001:470:27:46e::2/64

He-tunnel end point: 2001:470:27:46e::1

To be sure what was going wrong i used tcpdump to see were trafficker got stuck.

ping6 ipv6.google.com on router laptop

13:59:32.942350 IP tserv1.sto1.he.net > h186n23-vb-a11.ias.bredband.telia.com: IP6 arn02s05-in-x0e.1e100.net > Kex4King-1-pt.tunnel.tserv24.sto1.ipv6.he.net: ICMP6, echo reply, seq 22, length 64

ping6 ipv6.google.com on my laptop

14:01:42.112935 IP h186n23-vb-a11.ias.bredband.telia.com > tserv1.sto1.he.net: IP6 arn09s11-in-x0e.1e100.net > 2001:470:27:46e:87af:3d24:a865:8691: ICMP6, echo reply, seq 13, length 64

14:01:43.082344 IP h186n23-vb-a11.ias.bredband.telia.com > tserv1.sto1.he.net: IP6 2001:470:27:46e:87af:3d24:a865:8691 > arn09s11-in-x0e.1e100.net: ICMP6, echo request, seq 14, length 64

One thing I have tried was to make the tunnel my gateway in /etc/network/interfaces it didn’t work bu it gave me a new IP address

iface wlan0 inet6 auto
        gateway 2001:470:27:46e::1

wlan0 2001:470:27:46e:4a5d:60ff:fe9f:25b1/64

I also tried turning of IPv6 on eth0 and to have tried to only allow IPv6 forwarding on interface wlan0 and he-ipv6

/etc/sysctl.conf
net.ipv6.conf.eth0.disable_ipv6=0
net.ipv6.conf.wlan0.forwarding=1
net.ipv6.conf.he-ipv6.forwarding=1

It did not work at all

I have previously posted about this on Debian forum there you can see some more out puts and config files. http://forums.debian.net/viewtopic.php?f=30&t=131134

/etc/network/interfaces

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
hostapd /etc/hostapd/hostapd.conf
address 192.168.0.10
netmask 255.255.255.0

iface wlan0 inet6 auto
        gateway 2001:470:27:46e::2

auto he-ipv6
iface he-ipv6 inet6 v4tunnel
        address 2001:470:27:46e::2
        netmask 64
        endpoint 216.66.80.90
        local 81.234.63.186
        ttl 255
        gateway 2001:470:27:46e::1

and

/etc/sysctl.conf

net.ipv4.ip_forward=1

net.ipv6.conf.all.forwarding=1

Thanks in advance for any help.

  • I have a little difficulty understanding what works and what doesn't, but I see you are getting an ICMPv6 reply from Google, so your tunnel seems to work. The encapsulated IPv6 packets should go through your ISP, how would they otherwise reach the Internet? Am I missing something? – Johan Myréen Jan 11 '17 at 15:20
  • Ping from my router laptop gives “64 bytes from arn09s11-in-x0e.1e100.net: icmp_seq=1 ttl=53 time=27.3 ms” Working! Ping from my laptop gives “ping: sendmsg: Network is unreachable” but i can ping wlan0s IPv6 address on the router laptop so IPv6 is working. But you are right it is really weird and very new to IPv6 so i was hoping some on could help me to get it. My thinking is that the first ping from router laptop takes the rout “tserv1.sto1.he.net > ISP”. My laptop is taking the rout “ISP > tserv1.sto1.he.net”. Thanks for the fast reply hope this explained it. – VildKort Jan 11 '17 at 15:58
  • Are the eth0 and wlan0 interfaces bridged on the router laptop? – Johan Myréen Jan 11 '17 at 16:08
  • If the interfaces are not bridged they are separated on the IP layer, which means they should be on separate subnets. Based on your listings on the Debian forum, this is the case with IPv4, but you should do this with IPv6 too. Or bridge the interfaces. – Johan Myréen Jan 11 '17 at 18:46
0

Hi Thanks Johan Myreen you were right but I still had some trouble getting it to work. I started following this guide https://scottlinux.com/2014/04/28/debian-linux-home-router-with-ipv4-and-ipv6/ it is a similar setup as for me but between interface eth0 and eth1 I figured it could yest as well been eth0 and wlan0. At first I read the guide wrong and got the IP address in radvd a little mixed up but at last it’s done. In the guide the recommend a static IP on eth1 or in my case wlan0 for me auto worked fine as long as I changed the IP in radvd.

radvd.conf
prefix 2001:470:28:46e::/64

Now its all good, Johan if I had your address i would send you a cake :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.