I have been practising setting up a production environment with puppet, and now I'm setting up everything to accommodate HTTP requests with Apache.
Since Puppet runs on Ruby, I also need Passenger to get it running, but I can't install it because I keep getting an error saying that I need a fresher version of Ruby installed. At first this was an actual issue because I'm using a core version of CentOS 6.5 that only comes with Ruby 1.8.
I then updated the yum repos, the system itself and did
wget to download the current version, configured and installed which gets me to where I stand right now. I installed Gems and tried to get Passenger again but I am faced with the same wall, version problems.
Here you can see the installed version of ruby and the issue.
[vagrant@puppetmaster ~]$ sudo gem install rack passenger ERROR: Error installing rack: rack requires Ruby version >= 2.2.2. ERROR: Error installing passenger: rake requires Ruby version >= 1.9.3. [vagrant@puppetmaster ~]$ ruby --version ruby 2.4.0p0 (2016-12-24 revision 57164) [x86_64-linux]