I have been practising setting up a production environment with puppet, and now I'm setting up everything to accommodate HTTP requests with Apache.

Since Puppet runs on Ruby, I also need Passenger to get it running, but I can't install it because I keep getting an error saying that I need a fresher version of Ruby installed. At first this was an actual issue because I'm using a core version of CentOS 6.5 that only comes with Ruby 1.8.

I then updated the yum repos, the system itself and did wget to download the current version, configured and installed which gets me to where I stand right now. I installed Gems and tried to get Passenger again but I am faced with the same wall, version problems. Here you can see the installed version of ruby and the issue.

[vagrant@puppetmaster ~]$ sudo gem install rack passenger
ERROR:  Error installing rack:
        rack requires Ruby version >= 2.2.2.
ERROR:  Error installing passenger:
        rake requires Ruby version >= 1.9.3.
[vagrant@puppetmaster ~]$ ruby --version
ruby 2.4.0p0 (2016-12-24 revision 57164) [x86_64-linux]
  • 1
    Have you googled for it? I have found several results with a similar issue. Jan 11, 2017 at 14:18
  • Please don't post images of text. I have transcribed the contents for you, but you may want to check for errors in transcription.
    – Fox
    May 6, 2017 at 23:13

1 Answer 1


Well, after a couple of hours of searching and a lot of failed solutions on Google I finally found something that did actually work. The following commands actually solved it.

sudo gem install rack -v 1.6.0
sudo gem install rake -v 10.4.2
sudo gem install passenger -v 4.0.56

Apparently it's what everyone else was saying about source issues, just their solutions were not working in my case.

  • You can accept your own answer to let others know that the problem has been solved
    – Fox
    May 6, 2017 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.