0

I have two seagate expansion drives, the first one is 3.5'' 1.5TB and the second one is 2.5'' 2TB. The latter is partitioned and I installed Ubuntu 16.04 in it.

The day before I booted up with the latter expansion disk and plugged in the first expansion disk to move documents in it. It's rather old disk, I bought it about 7 years ago, it acts up sometimes, and makes click-cluck noise. I needed to plug in receiver of wireless mouse so I suspended the comp and changed the usb ports.

First Position: 3.5''Expansion--->USB PORT1, 2.5''Expansion--->USB PORT2

Final Position: 3.5''Expansion--->USB PORT2, 2.5''Expansion--->USB PORT1

And I let it resume, I should have lost my mind, as you know it resumed but froze immediately, because it could not read and write to 2.5''Expansion--->USB PORT2. I did a hard boot, it loaded the session but did not detected the old 3.5''Expansion , I shut down the comp because it was late at night.

Yesterday I started the comp and tried to open 3.5''Expansion but it wouldn't detect it. I tried to unplug and plug the power cable of 3.5''Expansion, none didn't work. I also tried it on Windows, it only detected it as a usb device, but can not view the content. I also checked it on drivers list in computer management, it's not listed. On Ubuntu it's listed in /dev/sdc. I tried to mount it like

 sudo mount /dev/sdc /mnt

but it hangs

Now I fear that it blew up when I interchanged usb ports.

How can I know about what happened to my 3.5''Expansion?

EDIT: output of dmesg

EDIT2: In Windows right-click Computer->Manage-> in the left panel under Storage -> Disk Management, clicking it and on the right panel my USB HDD appears but it is shrinked around 3GB. When I right click it, menu items grayed out. When I restarted it asks me gpt or mbr I tried each one respectively, but both failed to start the drive.

[ 6751.442410] usb 2-5: new high-speed USB device number 4 using ehci-pci
[ 6751.573306] usb 2-5: New USB device found, idVendor=0bc2, idProduct=3300
[ 6751.573316] usb 2-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 6751.573322] usb 2-5: Product: Desktop         
[ 6751.573328] usb 2-5: Manufacturer: Seagate 
[ 6751.573333] usb 2-5: SerialNumber: 00000000    
[ 6751.573984] usb-storage 2-5:1.0: USB Mass Storage device detected
[ 6751.578845] scsi host6: usb-storage 2-5:1.0
[ 6752.576847] scsi 6:0:0:0: Direct-Access     Seagate  Desktop          0130 PQ: 0 ANSI: 4
[ 6752.582198] sd 6:0:0:0: Attached scsi generic sg3 type 0
[ 6752.582847] sd 6:0:0:0: [sdc] 8089949 512-byte logical blocks: (4.14 GB/3.86 GiB)
[ 6752.583607] sd 6:0:0:0: [sdc] Write Protect is off
[ 6752.583621] sd 6:0:0:0: [sdc] Mode Sense: 2f 08 00 00
[ 6752.584464] sd 6:0:0:0: [sdc] No Caching mode page found
[ 6752.584475] sd 6:0:0:0: [sdc] Assuming drive cache: write through
[ 6752.588580] sd 6:0:0:0: [sdc] tag#0 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
[ 6752.588593] sd 6:0:0:0: [sdc] tag#0 Sense Key : Illegal Request [current] 
[ 6752.588602] sd 6:0:0:0: [sdc] tag#0 Add. Sense: Logical block address out of range
[ 6752.588610] sd 6:0:0:0: [sdc] tag#0 CDB: Read(10) 28 00 00 00 00 00 00 00 01 00
[ 6752.588617] blk_update_request: critical target error, dev sdc, sector 0
[ 6752.588626] Buffer I/O error on dev sdc, logical block 0, async page read
  • No should not break the hardware. – ctrl-alt-delor Jan 11 '17 at 15:50
  • @richard thank you for responding. I feel better and sensible – kenn Jan 11 '17 at 16:05
  • In general, if your HDD "acts up" and makes clicking noises, it's high time to run smartctl on it to see if it's about to fail, and make a backup. It may be too late to do that now, though. But you can still find out how bad it is: Unplug all external disks and boot. Plug in the bad HDD, and post the end of dmesg resp. syslog after the "new USB ... device" line. If it appears as /dev/sdc etc., run smartctl -a /dev/sdc on it (as root) and post the output. – dirkt Jan 11 '17 at 18:06
  • @dirkt Thank you for your help. I just posted the dmesg output. Some suggest extracting harddisk in the box, and plug it into a computer. – kenn Jan 12 '17 at 13:07
  • The total capacity is wrong, so something is severely broken, and I'm not surprised the read doesn't succeed. What is the output of smartctl -a /dev/sdc? Taking it out of the enclosure, and directly connecting it via SATA can help if it's the USB-SATA-bridge which is broken for some reason. It won't help if the harddisk is broken, but it's worth a try. But check the SMART stuff first. – dirkt Jan 12 '17 at 15:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.