1

I use neovim in tmux in gnome-terminal on Fedora 25. Here I found out, that I do not have true color support because terminal is not linked to some libvte of correct version. Since many nvim color schemes need true color support (and also I want this from a general perspective) I'd like to activate it!

However, the posted site only refers to the ppa (which as I imagine are ubuntu-repos). So my question: How do I activate true colors in gnome-terminal on fedora 25?

  • 1
    If you downvote, please at least comment, what can be improved in the question. I've serached high and low and did not find anything on the topic (except for Ubuntu SE and other ubuntu only solutions) so this should be no reason. – mike Jan 11 '17 at 17:12
  • You need to make better research before ask. – X3MBoy Jan 12 '17 at 12:57
  • Nearly every question here can be answered by some page on the web or some docu etc. However, most of the time people who ask just do not stumble across their perfect result just so... But thanks for the positive attitude! – mike Jan 12 '17 at 15:30
4

Those instructions do not actually provide the correct test for the version of libvte used on Fedora, since our gnome-terminal-server is in /usr/libexec. Instead, I'd suggest

$ rpm -qR gnome-terminal|grep vte
libvte-2.91.so.0()(64bit)
vte291(x86-64) >= 0.46.0

Here, we see that 0.46.0 is greater than the 0.36 your tutorial says is required, so this is not your problem. In fact, check this out:

$ echo $COLORTERM
truecolor

TrueColor is already enabled out of the box on Fedora 25 Workstation.

$COLORTERM is also truecolor inside of tmux. In fact, this blog post has a simple test script with which I verified that TrueColor is in fact working both outside and inside tmux with no further configuration.

So, this is down to neovim configuration. To make it work in current versions, you need set termguicolors in your ~/.config/nvim/init.vim. (In versions before May 2016, set the environment variable NVIM_TUI_ENABLE_TRUE_COLOR to 1.) This is documented in the neovim log of "breaking changes".

  • Thanks! The blog post was actually the fix. It happend to be the setup of neovim, which I did not have set up. Thank you! – mike Jan 11 '17 at 18:36
  • Aha! NVIM_TUI_ENABLE_TRUE_COLOR=1. Glad I could help. – mattdm Jan 11 '17 at 18:43
  • actually Jakob Lundberg pointed out, that this variable is unused now, since this patch. The new statement is: if has(“termguicolors”) set termguicolors endif – mike Jan 11 '17 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.