2

I have installed trusty64 in vagrant and while trying to start with vagrant up I am unable to connect via SSH. Its saying about SSH Time but I am sure its not something to do with SSH connectivity

Please check below log

sniper@openstackm1:/playbooks$ vagrant reload
==> default: Attempting graceful shutdown of VM...
    default: Guest communication could not be established! This is usually because
    default: SSH is not running, the authentication information was changed,
    default: or some other networking issue. Vagrant will force halt, if
    default: capable.
==> default: Forcing shutdown of VM...
==> default: Clearing any previously set forwarded ports...
==> default: Clearing any previously set network interfaces...
==> default: Preparing network interfaces based on configuration...
    default: Adapter 1: nat
==> default: Forwarding ports...
    default: 22 (guest) => 2222 (host) (adapter 1)
==> default: Running 'pre-boot' VM customizations...
==> default: Booting VM...
==> default: Waiting for machine to boot. This may take a few minutes...
    default: SSH address: 127.0.0.1:2222
    default: SSH username: vagrant
    default: SSH auth method: private key

Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured ("config.vm.boot_timeout" value) time period.

If you look above, you should be able to see the error(s) that
Vagrant had when attempting to connect to the machine. These errors
are usually good hints as to what may be wrong.

If you're using a custom box, make sure that networking is properly
working and you're able to connect to the machine. It is a common
problem that networking isn't setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout ("config.vm.boot_timeout") value.
3

Had the same problem. Noticed my VirtualBox does not have 64bit Linux in the option list. Try goto Bios and enable Intel Virtualization Technology. Works for me.

  • Worked for me too – sinaza Sep 12 '17 at 7:14
1

It would be easier to assist with provided Vagrantfile and at least information on Vagrant provider. There are many ways how to configure Vagrant, providers and plenty of boxes.


I assume you're using default VirtualBox provider

The message which is most important is Timed out while waiting for the machine to boot.. Vagrant is trying to connect to the machine (via 127.0.0.1:2222) and it can't connect for some reason we don't know yet.

Some steps to diagnose:

  1. Open VirtualBox GUI, open your guest machine and verify it's booted and ready to login.

  2. You should probably login to the machine console with login vagrant and password vagrant. (Some of Ubuntu boxes uses login ubuntu. see)

  3. If you're able to login as vagrant user, check networking in your virtual machine. Networking should be up and you should be able to connect to outer world.

  4. Check your virtual machine is running ssh and accepting connections on port 22.

  5. Check that TCP connection (on your host) to 127.0.0.1:2222 is forwarded to your guest. It should be set in VirtualBox machine setting (somewhere in Networking).

  6. Test another Vagrant box. I'm prefer geerlingguy/ubuntu1404 personally, because I dislike the Ubuntu approach of not using standard vagrant user.

If some of these steps shows itself failing, try to figure where the issue is hidden.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.