6

During installation I got a few pop ups stating that hardware needs non-free firmware files to operate. At that time I didn't have those files so I continued with the installation, but now my now system is not able to recognize wifi. I tried installing firmware but whatever from searching from didn't at all work.

The missing files are:

  • rtlwifi/rtl8723befw.bin
  • rtlwifi/rtl8723befw.bin

Now I completed the installation, how can I install the firmware?

3 Answers 3

12

You need to enable non-free first: edit /etc/apt/sources.list, and at the end of lines ending with main, add contrib non-free. You'll end up with something like

deb http://ftp.fr.debian.org/debian jessie main contrib non-free

etc.

Then update your repositories and install firmware-realtek:

apt-get update && apt-get install firmware-realtek

That will provide the necessary firmware files.

1
  • Thank you. Many guides to this process say something like "add non-free to your sources" without saying what that means specifically. Commented Apr 3, 2023 at 21:14
2

If you have a wired internet connection you can install sudo apt-get install firmware-linux-nonfree

Alternative way in Debian 8 Jessie:

Download firmware.zip or tar.gz from here :

and extract all files of the zipped archive in folder /lib/firmware and then restart.
See also Debian Wiki :

Provide Firmware during installation:
Just for the record when i want to be sure that all recent firmware will be available during a fresh Debian Jessie installation i follow these steps:

  • I download the Debian 8 iso image i like (stable, testing, etc)
  • I burn Debian iso image to a usb stick
  • I download seperately the package firmware.tar.gz
  • I copy firmware.tar.gz inside folder "firmware" of the installation cd.
  • I extract firmware.tar.gz inside folder "firmware" of installation cd by using "extract here" option
  • I accept any overwrite messages.
  • Finally i boot with usb stick and firmware it is just there for sure.
  • PS: I do the same procedure even if the Debian iso image claims that contains nonfree firmware, because in reality it has turned out that firmware maybe missing even from such iso images.
3
  • It says there is no such package... Commented Jan 11, 2017 at 9:04
  • If you run apt list "firmware*" do you get any results? Also make first sudo apt-get update && apt-get upgrade && apt-get dist-upgrade Commented Jan 11, 2017 at 9:13
  • @SarfrazRoboRex Check the alternative solution Commented Jan 11, 2017 at 9:19
0

For Debian Buster, with internet access, a mix of the two other response is what you need to go :

You need to enable non-free first: edit /etc/apt/sources.list, and at the end of lines ending with main, add contrib non-free. You'll end up with something like

deb http://ftp.fr.debian.org/debian buster main contrib non-free

Once that's saved, update the indexes with the new package lists:

sudo apt update

You can now install

sudo apt install firmware-linux-nonfree

and eventually:

sudo apt install firmware-realtek

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .