I recently installed an SSD and have been trying to install Debian on it. For a few reasons it has been difficult on this machine; at the moment I've installed everything but it is failing to boot. Whenever I try to manually boot my install grub freezes after: linux /boot/vmlinuz... root=/dev/sda1 This is the second install where this issue has occurred.

In case it's relevant, in the past when I'd install debian I would always have to chroot from a live-cd or old install and install my video card driver. If not grub would freeze like it is doing now, although I never tried manually booting so I'm not sure it was failing at this step. Of course before trying to boot this time I followed all of the steps that have worked before.

I'm not getting any debug information. Is there perhaps a verbose mode for grub or does anyone have something I can try?

Edit: as an experiment I copied the kernel and initramfs to my other drive and tried booting from those. It brought me to the initramfs prompt where when I try to manually mount sda1 it tells me no such file or directory.

Clarification: Above when I saw manually boot, I mean that I'm in grub console trying to type something like

grub> set root=(hd0,1)
grub> linux /boot/vmlinuz-3.13.0-29-generic root=/dev/sda1
grub> initrd /boot/initrd.img-3.13.0-29-generic
grub> boot

But grub stops responding after I load either the kernel or the initrd from the ssd.


I retried what I did in the edit above and it is successfully booting now without going to the initramfs prompt. (perhaps I had a typo somewhere before) I'm not making this a solution because GRUB is only able to load the kernel and initrd from my second drive and not my ssd.

  • 1) Are you perhaps missing an initramfs? 2) Are you sure your root partition is on /dev/sda1? – Julie Pelletier Jan 11 '17 at 4:16
  • @JuliePelletier Grub freezes before I can load the initramfs and under grub my ssd is hd0 and my old install even has the ssd under sda. – David Jan 11 '17 at 4:19
  • 1
    try booting with removed quiet kernel parameter, and the boot sequence will be more verbose. – Ipor Sircer Jan 11 '17 at 4:52
  • @Sircer loading the kernel (off the ssd) into memory is when it freezes. That is before I execute boot. – David Jan 11 '17 at 4:59
  • 1
    Set up a gparted usb, and fsck the filesystems, as well as checking that the partitions are still there – Cyclic3 Jan 16 '17 at 18:02

The installation guide lists a number of optional boot parameters you can add to the Grub command line and see if anything helps. There is also an alternate Debian CD with different drivers which you could try.

The troubleshooting section of the installation guide is several pages long and points to various other sections for details; you will probably want to read at least the main parts: https://www.debian.org/releases/stable/i386/ch05s04.html

  • Did you not read the comments above? Grub freezes when loading the kernel. How will boot parameters help if the kernel never in memory? – David Jan 18 '17 at 23:25
  • 1
    @David - Loading the kernel is a quite quick action. The kernel can pretty much be the thing that is freezing. Between the kernel entering the memory and outputting the first thing to the terminal is a long road, and parameter parsing do happen in that time. It takes time before the kernel figures out how to output to the terminal. – grochmal Jan 19 '17 at 2:06
  • @grochmal by manually boot I mean that I'm typing the commands into grub console. Editing question to clarify that. So grub freezes after I tell it to load the kernel and before I tell it to boot. – David Jan 19 '17 at 3:19
  • 2
    @David I don't see what makes you think that kernel parameters can't help. They'd go in the linux /boot/vmlinuz-3.13.0-29-generic ... line. And no, don't assume people have read the comments. If something is relevant, you need to add it to your question. – terdon Jan 19 '17 at 8:51
  • @ḾádḾőíśéĺĺé this isn't really answering the question though. You're just providing resources. Could you explain which kernel parameters you think could help? How to add them? Your answer needs to be helpful even if the links no longer work. Please copy the relevant information and include it here. – terdon Jan 19 '17 at 8:53

change your /etc/fstab

UUID=0784c0e3-d4c7-4ae4-ab48-0cd3b4fb3198 /  ext4   errors=remount-ro 0       1 

UUID=28c088fc-5045-4155-89f3-f1e43d903d4f  /tmp  ext4  defaults  0    2
UUID=5b784a02-4f23-4d10-898b-833dd49f815c  /home  ext4 defaults  0    2  

Your /etc/default/grub is almost emty?

dpkg -l | grep grub | awk '{print $2}' | xargs apt install --reinstall -y

This will reinstall all your Grub-packages. Then update-grub

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.