-1

I am trying to setup keybased authentication between Arch Linux and Ubuntu. Both OS are virtual installations(I know this doesnt matter but just FYI).

I have generated ssh key's with default options by using ssh-keygen command on both Arch and Ubuntu machines, And then copied public keys with ssh-copy-id command.

I am able to login from Arch machine to Ubuntu machine successfully.

[raja@archserver ~]$ ssh sniper@192.168.106.106
Welcome to Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-57-generic x86_64)

 * Documentation:  https://help.ubuntu.com
 * Management:     https://landscape.canonical.com
 * Support:        https://ubuntu.com/advantage

0 packages can be updated.
0 updates are security updates.


Last login: Tue Jan 10 16:30:51 2017 from 192.168.106.1
sniper@openstackm1:~$

But I am unable to login via key-based authentication from Arch machine to Ubuntu machine and when I tried I am getting prompt for password. I havent done any modifications to both sshd_config files but Ubuntu accepting but Arch doesnt.

sniper@openstackm1:~$ ssh jboss@archserver
jboss@archserver's password:

Please help.

closed as too broad by Ipor Sircer, GAD3R, countermode, Kusalananda, mdpc Jan 10 '17 at 22:12

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Do you get any additional insights when using the -v flag on your failing ssh command? ssh -v jboss@archserver – Emeric Jan 10 '17 at 11:37
  • @To close over , Why it is too broad ? You ask me what you need to understand and I am ready to provide that information. You have right to have your opinion but making your opinion as a statement isnt right. – rɑːdʒɑ Jan 10 '17 at 11:37
  • 1
    @Emeric may be due to this ? debug1: Skipping ssh-dss key /home/sniper/.ssh/id_dsa - not in PubkeyAcceptedKeyTypes – rɑːdʒɑ Jan 10 '17 at 11:39
  • Yes, that looks like a plausible cause. OpenSSH does not like DSA too much anymore. If you don't have the option to generate other types of keys (rsa would be likely valid), you can add +ssh-dss in your ssh_config to allow it. – Emeric Jan 10 '17 at 11:45
  • @Emeric Thank you , I am working on it. I will let you know. – rɑːdʒɑ Jan 10 '17 at 11:53
2

OpenSSH does not like DSA too much anymore, and started disabling it by default. If you don't have the option to generate other types of keys (rsa would be likely valid), you can add +ssh-dss in your ssh_config to allow it.

Not the answer you're looking for? Browse other questions tagged or ask your own question.