1

I just installed texmaker and kate in my fedora 24 system. The problem is that they appear "zoomed in" and they cannot function properly as the following picture shows

enter image description here

However, I have a clue on what might be the issue. When I installed VLC, the video was appearing on the left bottom corner of the interface, so I added these lines to my .bashrc file

# VLC - Full screen 
QT_SCREEN_SCALE_FACTORS=0.5
export QT_SCREEN_SCALE_FACTORS

so I think that this is what causes kate and texmaker to appear zoomed in.

Any idea on how to fix this but having vlc showing the videos properly?

UPDATE

I changed my bashrc entry to

# VLC - Full screen 
alias vlc='QT_SCREEN_SCALE_FACTORS=0.5 vlc'

I also installed qtcurve and now the behavior is better but still strange :

TexMakeR and Kate work properly only when opening a file using right click -> Open. Rather oddly, double clicking on a file or opening the programs (either on terminal or in Applications->Accessories) results in the same strange behavior (i.e. program appears "zoomed in").

  • I had similar problem with VLC in previous Fedora versions, but Fedora 25 works fine. So I would recommend you to upgrade to Fedora 25. Also downgrade of VLC might help temporarily. – Jakuje Jan 10 '17 at 11:18
  • @Jakuje Thank you very much for your comment. At the moment I don't want to upgrade to fedora 25 (It's my business laptop and it has to have fedora 24) and downgrading vlc didn't work... – Thanos Jan 10 '17 at 13:20
  • Did you try to comment these lines in your .bashrc, resource it (or restart) and try again? Your problem is basically Qt Libraries Look&Feel over GTK (XFCE to be specific) so maybe you can try qtcurve (is in fedora repos: dnf install qtcurve) and/or try to configure your Qt behavior with qtconfig (qt3 and qt4) or qt5ct (Qt5 Config Tool). – X3MBoy Jan 12 '17 at 13:46
  • @X3MBoy : Thank you very much for your comment. Please see my updated question. – Thanos Jan 16 '17 at 15:08
  • For your update, you should check the command on the .desktop file Menú entries are just "launchers", these are text files with .desktop extensions that contains a command to execute something (normally applications). If you link wour file with the option "Open with", you can customize the start of the program, but I don't what is the difference between xdg-open (double-click a file) or running the command. IMHO you should test running the application from terminal unsetting the QT_SCREEN_SCALE_FACTORS variable first > unset QT_SCREEN_SCALE_FACTORS; kate – X3MBoy Jan 17 '17 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.