1

new Linux user here, I am using chaletOS. I'm trying to install and run android-studio.

After I try to run studio.sh, an error window pops up that reads: Unsupported Java Version: Cannot start under Java 1.7.0_121-b00: Java 1.8 or later is required. Unsupported Java Version: Cannot start under Java 1.7.0_121-b

However I just installed the latest version of Java, it is now sitting in /Desktop/ in a folder labeled jre1.8.0_111

What am I missing here? Any help much appreciated.

2
  • can you put the output of the command java -version Jan 10, 2017 at 10:14
  • You need to install openjdk 1.8 not jre 1.8. Android didnt need java from oracle again.
    – supriady
    Jan 10, 2017 at 12:08

2 Answers 2

1

I too encountered the same issue recently

and i found the solution as :


$ sudo vim /etc/apt/sources.list.d/java-8-debian.list

and add these two lines:

deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main

$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys EEA14886
$ sudo apt-get update.
$ sudo apt-get install oracle-java8-installer

Check if it is installed properly.

zeus@debian:~$ java -version
java version "1.8.0_121"
Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
Java HotSpot(TM) 64-Bit Server VM (build 25.121-b13, mixed mode)

Make as default.

$ sudo apt-get install oracle-java8-set-default
0
0

I'm using the lastest android studio, i didn't install jdk and it worked.

See here:

A copy of the latest OpenJDK comes bundled with Android Studio 2.2 and higher, and this is the JDK version we recommend you use for your Android projects. To use the bundled JDK, proceed as follows:

  1. Open your project in Android Studio and select File > Project Structure in the menu bar.
  2. In the SDK Location page and under JDK location, check the Use embedded JDK checkbox.
  3. Click OK.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .