When running command lines in bash... lets say I run a command that outputs some info to the screen. In that text screen of info are several URLs. In bash, you can right click the URL text and select "Open Link"... which would supposedly open your default browser and open the link with that. However, I get an error instead. Its a little grey box that has a title, "Error - Konsole" and says: "Could not connect to host Connection refused."

I'm not sure why its trying to connect to my localhost. It doesn't matter what the URL points to, the error is the same. It never even attempts to open FireFox, my default browser. I can tell this, because FireFox always has a delay to open and respond to anything. However, this error is instantaneous. Not to mention again, the title is "Error - Konsole". So this is not a FireFox issue. It seems like its trying to route to a local proxy or something. That is just a guess, I have no clue.

Here are some things:

-- I know the "Konsole" is the terminal emulator for KDE, if that helps.

-- " Could not connect to host Connection refused " might be a similar issue.. or the same. (I do not think it was properly solved.)

Does anyone have any ideas? Can anyone help or offer a suggestion?

If not, a secondary question. How do I check my proxies?

(I have Linux Mint 17.3 KDE Desktop)


1 Answer 1


I would look at Settings->Applications->Default Applications->Web Browser to be sure that correctly points to a web browser on your system. Then, as a bit more of a long shot, I would try launching a URL displayed on a different terminal, for example xterm.

I was not able to reproduce your problem using KDE on Linux Mint with konsole and firefox as the web browser. I was using Mint version 18 however, and in a Qemu-KVM virtual machine.

  • Thanks! That was it. On that screen it says "Open http and https URLs" and there was a radio box to select between: "in an application based on the contents of the URL" and "in the following browser: <blank combobox>". So, I put the radio box on "in the following browser" and picked FireFox from the list.. Now it all works fine. There was also an application that had a button that opened a website. It was not working. It is now working as well. One thing to question. Why didn't it recognize the contents of the URL correctly? Jan 10, 2017 at 16:12
  • Which radio box was originally selected? Was "in the following browser" selected with a blank field or was "in an application based on the contents of the URL" selected? I ask this mainly to direct you towards an answer as I'm not sure right off. If you are really curious I'd open a new question. Actually, I also would be interested to know why it exhibited that specific behavior.
    – airhuff
    Jan 10, 2017 at 19:24
  • Agreed, that's why I was asking. It does seem odd that it seems to fail to detect a standard HTTP-type URL and then tries to connect to localhost. The radio button started on "in an application based on the contents of the URL". I switched it to "in the following browser". Jan 11, 2017 at 15:50
  • Yea, one of those things that's great to have it fixed but would be nice to understand the behavior exhibited. I'll look into it more also.
    – airhuff
    Jan 11, 2017 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.