I'm running linux mint on an asus laptop.

Throughout multiple installs of linux (always mint, but different environments), the clock is always wrong sometimes.

It's not off by an even multiple of an hour of half-hour, it can be off by seemingly random times.

I remember having a service on an old install along the lines of datectl, however in order to actually fix the problem, the service would have to be restarted.

I haven't seen it change on me, so I can assume that it's only when coming out of sleep/booting.

Is this a bad CMOS clock battery? I would have thought that a service would be able to compensate for this.

1 Answer 1


First of all i recommend you to install ntp service with apt-get install ntp.

To sync the hardware clock with the system clock you can use hwclock command with option --systohc or -w

hwclock -w

this will set the hardware clock to the current system time

  • As of 11/22, This no longer works on Linux Mint 21, kernel 5.15.0-52-generic
    – mccurcio
    Nov 7, 2022 at 14:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .