1

When I start Debian, the GUI is not starting. It goes to command line asking for login.

andre@move-01:~$ systemctl status gdm3 service
* gdm.service - GNOME Display Manager
   Loaded: loaded (/lib/systemd/system/gdm.service; enabled)
   Active: active (running) since Mon 2017-01-09 13:32:21 BRST; 12min ago
  Process: 952 ExecStartPre=/usr/share/gdm/generate-config (code=exited, status=0/SUCCESS)
  Process: 952 ExecStartPre=/bin/sh -c [ "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/sbin/gdm3" ] (code=exited, status=0/SUCCESS)
 Main PID: 958 (gdm3)
   CGroup: /system.slice/gdm.serivce
              958 /usr/sbin/gdm3
             1609 /usr/bin/Xorg :1 -novtswitch -background none -noreset -verbose 3 -auth /var/run/gdm3/auth-for-Debian-gdm-0Mifhr/database -seat seat0 -nolisten tcp vt7

* service.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

When I try to sudo startx, I get this:

(EE)
Fatal server error:
(EE) Can't read lock file /tmp/.X0-lock
(EE)
(EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
(EE)
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

Other commands I've tried:

update-rc.d -f gdm defaults
sudo /etc/init.d/gdm3 stop && startx

What's going on?

(There are similar questions, but neither of them worked for me.)


EDIT

Output for sudo journalctl -u gdm3:

-- Logs begin at Mon 2017-01-09 13:55:54 BRST, end at Mon 2017-01-09 14:25:33 BRST. --

EDIT 2

lspci | grep VGA output:

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc.  [AMD/ATI] Tahi
 PRO  [Radeon HD 7950/8950 OEM / R9 280]
1

For Nvidia-card try Bootoption nouveau.modeset=0

For Intel i915.modeset=0

This disable the KMS

| improve this answer | |
  • +1, but my computer is AMD and no nvidia card. – João Paulo Jan 9 '17 at 16:45
  • Then radeon.modeset=0 But I am not familiar with amd/radeon cards. – user192526 Jan 9 '17 at 16:51
  • Nice, I'll try! – João Paulo Jan 9 '17 at 16:53
  • Are you using the opensource driver or the fglrx (closed source) one? – Bigon Jan 9 '17 at 16:57
  • @Bahamut Tried radeon.modeset=0, but nothing changed, only resolution changed, It reduced, I got big letters. @Bigon man, I don't know which one I'm using... :( – João Paulo Jan 9 '17 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.