0

I've been trying to set up the Xbox 360 controller, usb connected, under wine with x360ce as shown here so I can play with it. Have been few days now and after hitting the head against the wall few times, decided to give up a bit and ask in case someone can shed some light to the matter.

So, I'm running Debian stretch 64 bits and my version of wine is 2.0-rc3. xboxdrv is installed and working fine on native linux games. There is a Steam Controller connected to the machine too and the real tone cable from Rocksmith too (this one works fine out of the box as well)

I do as follows:

WINEPREFIX="$HOME/x360ce" WINEARCH=win32 wine wineboot
export WINEPREFIX="$HOME/x360ce"

After that I navigate till x360ce folder and download the latest winetricks from its GitHub fork. After that I type this:

bash winetricks -q dotnet45 corefonts

The installation goes well, then I proceed to download x360ce file, unzip it and execute it. I create the dll (xinput1_3.dll) I can then re-map the buttons and hit save, which originates a x360ce.ini file. As I can do the mappings just fine I supposed wine was then able to see my controller...

Now another 32 bits prefix is created, in which I will install steam, and The Last Remnant and Batman Arkham Asylum, 2 games reported as working with Wine + controller.

WINEPREFIX="$HOME/wine32" WINEARCH=win32 wine wineboot
export WINEPREFIX="$HOME/wine32"

Anyway, after that, I place the files into the folder of given games where the binaries to execute the game are. Launch the game and surprise! It doesn't work.

Funny enough, if I try to open x360ce again, after exporting it's prefix variable first, I get a parsing error from Microsoft .NET.

I have tried to override dll direction's in both prefixes via winecfg installing Directx9 independently, also tried to run the games, without steam for windows open, as a launcher from steam for linux and that didn't work either. I have also tried to install the script from Kokutoru, here, but not avail.

For more I search on the internet people don't seem to have a real problem to make this work and I'm running out of ideas.

What am I doing wrong? Any help or hints you might have?

Thank you very much in advance.

0

What I did to solve the issue, after proceeding creating the prefixes for the games as stated above, was deleteing the prefix for x360ce and using dumxinput from kozec instead. In order to make the Steam Controller work under Wine I also installed sc-controller. To add the repository and install it I did:

echo 'deb http://download.opensuse.org/repositories/home:/kozec/Debian_9.0/ /' > /etc/apt/sources.list.d/sc-controller.list wget -nv https://download.opensuse.org/repositories/home:kozec/Debian_9.0/Release.key -O Release.key apt-key add - < Release.key apt-get update apt-get install sc-controller

To add dumbxinput I placed xinput1_3.dll and xinput9_1_0.dll next to the game executable. On Wine, using winecfg, set the respectives DLL overrides as "native" and start the game.

Don't forget to start sc-controller first starting the game to use Steam Controller under Wine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.