1

I have a xonar DG asus on slackware linux(module is snd-oxygen) Works perfect but only if select as analog output the multichannel as you can see from alsamixer

enter image description here

The problem is at reboot..the setting "analog output" return to "headphones" And i can get no sound until i redo alsamixer and select "multichannel" again. The command

alsactl --file ~/.config/asound.state store

doesn't work

-1

Solution found,on my .bash_profile i put this line

alsactl --file ~/.config/asound.state restore
  • So it looks like the "store" command did work, you just didn't know how to use it. :-) BTW, many distros restore the sound state on boot (e.g. Debian via alsa-utils, in /var/lib/alsa/asound.state), and save it on shutdown. – dirkt Jan 9 '17 at 7:50
  • 1
    If this is a system-wide setting, consider using /etc/rc.d/rc.local instead. – CL. Jan 9 '17 at 8:49
  • Yes i know rc.local is best for system-wide,but i use only with one user so .bash_profile is ok – elbarna Jan 9 '17 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.