2

As my old Ubuntu LTS 12.04 runs out of maintenance this year, I've setup a fresh system using Linux Mint 18.1 Cinnamon.

I am used to two independent clipboard buffers: Ctrl-C stores to the clipboard (which can be used with Ctrl-V then), while selecting text with the mouse goes to "primary" (which can be pasted via the middle mouse button then). That way I can copy two strings, and afterwards paste them separately.

This worked great ever since I started using Linux ~20 years ago. But now with Cinnamon, primary always gets copied to the clipboard automatically, leaving me with the same string in both buffers.

How to prevent that from happening?

Of course I have consulted other questions here, using the tag as well as search. Found several questions dealing with the very same issue, but none offered a solution to me:

and so on. I also used the DConf Editor to check for corresponding settings, no luck here either. Might have to do with how Cinnamon handles this (my primary guess), or the switch from X11 to Wayland is behind it (possible, but not that likely:¹ I've tried multiple clipboard managers like ClipIt, Glipper, and they could be configured to just consider one of the two for keeping snippets (while the system still copied things over)).

Any solutions?

UPDATE: I just noticed that both "buffers" stay separate while in graphical apps (i.e. Firefox text boxes, graphical editors etc) – but are merged as soon as I enter a text-based app (xterm, gnome-terminal). Maybe this gives a clue?


¹ Wayland ruled out. Though Mint 18.1 comes with some Wayland libs installed, it's running X11.

  • If you are using Wayland then, yes, the handling of the primary selection has changed. At one point it was not supported, but now seems to be. – meuh Jan 8 '17 at 16:01
  • @meuh I'm not sure if I am – how to find out? According to dpkg -l, there are 4 wayland libs installed, including libwayland-server0 – but also a lot of x11 libs. And ps aux doesn't show a single process matching either "wayland" or "x11", case insensitive. // Thanks for the link! Interesting read, but unfortunaly only talks about "we should" – but not how it might be enabled. – Izzy Jan 8 '17 at 18:48
  • 1
    If using systemd run loginctl to find your session number, eg 1, then run loginctl show-session 1 -p Type. It would say Type=x11 for good old X11. – meuh Jan 8 '17 at 19:06
  • Thanks, it does. So we can rule out Wayland being the issue here. Should make things easier. Is there some setting for e.g. ~/.xsessionrc? Or is it rather the display manager (mdm in my case) responsible for that? Did a recursive grep -i clip on /etc/X11, but couldn't find anything that seemed related. – Izzy Jan 8 '17 at 19:14
2

Having played with it a bit more first made things even more strange: in console mode, Shift-Insert seems to insert PRIMARY, not CLIPBOARD – so those are kept separate, as back in a graphical app (e.g. a textbox in Firefox), I am still able to Ctrl-V what I originally had CTRL-Cd there.

Checking further, CLIPBOARD is available in console via CTRL-SHIFT-V for pasting and CTRL-SHIFT-C for copying.

Conclusion: My question was wrong. It's the hotkeys that changed. So I might need to either get used to those key bindings – or ask a new question: how to change them (or modify Shift-Insert accordingly). But first I need to search if nobody else asked that already :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.