0

I have a dell T3620 workstation with nvidia NVS 315 video card.

I installed the video card driver with following commands:

yum remove xorg-x11-drv-nouveau*
yum install nvidia-x11-drv.x86_64 nvidia-x11-drv-32bit.x86_64
reboot

after reboot, I can run the nvidia-settings gui tool, but can't change the resolution, the highest resolution is 1024x768, but my LCD support up to 1600x900. My LCD only support VGA port, so i used a DVI to VGA convertor.

the xorg.conf is like this:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 375.26  (buildmeister@swio-display-x86-rhel47-01)  Thu Dec  8 19:06:44 PST 2016

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
    FontPath        "/usr/share/fonts/default/Type1"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: builtin, VertRefresh source: builtin
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-0"
    HorizSync       28.0 - 55.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVS 315"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "1024x768 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
1
  • I have tried to change Option "metamodes" "1024x768 +0+0" to Option "metamodes" "1600x900 +0+0" and now my centos show me this: Oh no! something has gone wrong A problem has occurred and the system can't recover please log out and try again. tab to the Log Out button, and press enter have no effect! how to resuce?
    – WestFarmer
    Commented Jan 8, 2017 at 8:45

1 Answer 1

0

You can use nvidia-xconfig, from a terminal. nvidia-xconfig will find the X configuration file and modify it to use the NVIDIA X driver. In most cases, you can simply answer "Yes" when the installer asks if it should run it. If you need to reconfigure your X server later, you can run nvidia-xconfig again from a terminal. nvidia-xconfig will make a backup copy of your configuration file before modifying it.

Note that the X server must be restarted for any changes to its configuration file to take effect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .