128

I'm on Ubuntu and I typed cat .bash_history | grep git and it returned

Binary file (standard input) matches

My bash_history does exist and there are many lines in it that starts with git.

What caused to display this error and how can I fix it?

4
20

Presumably the file .bash_history starts with non-text data, hence grep is treating the file as binary. This is confirmed by the file .bash_history output:

.bash_history: data 

You can read a few bytes from start to have a conforming view:

head -c1K .bash_history 

Here I am reading first 1 KiB.

You can pipe the STDOUT to hexdump/od or similar.


As a side note, grep takes filename(s) as argument, so cat is useless here; try this:

grep git .bash_history
7
  • 1
    I'm still not sure how to solve the grep issue, head -c1k .bash_history read the first 38 lines of my .bash_history file. Everything was readable – answerSeeker Jan 8 '17 at 5:22
  • 5
    @TatakaiWasumi Whats the output of grep -a git .bash_history? – heemayl Jan 8 '17 at 5:29
  • 1
    That worked! I got everything I wanted from it. What does -a do? – answerSeeker Jan 8 '17 at 5:31
  • 9
    @TatakaiWasumi -a makes grep to treat the file as binary. – heemayl Jan 8 '17 at 5:34
  • 8
    -a make grep process a binary file as if it were text. – lashgar Apr 6 '18 at 23:01
243

You can use grep -a 'pattern'.

from man grep page:

-a, --text
Process a binary file as if it were text; this is equivalent to the --binary-files=text option.

2
  • This has helped me when using the -z flag to match across several lines. – stragu Apr 24 '18 at 7:51
  • 1
    It has worked for me, but still weird because my file isn't a binary file. [grid@serverdg2 trace]$ file listener.log listener.log: data – Harry Dec 1 '20 at 3:42
4

I had the same problem when I want to grep my .bash_history. (Little Note: I renamed my history, so that a new one was created. This new history was not treated as a binary.)

In @heemayls answer it is stated, that grep takes filenames and cat would be useless. This is not entirely true. From greps man page:

If no files are specified, or if the file “-” is given, grep searches standard input.

So you could use cat and pipe it to grep. However this solves not the problem that .bash_history is treated as a binary. The only right thing is to use grep -a (Like in the answer from @AK_) whether you grep the history directly or with cat and a pipe.


cat .bash_history | grep -a git

or

grep -a git .bash_history
0
1

Error is due to the data in the file being binary, you can use strings command to see the human readable (i.e. strings) part which you would normally search using grep

strings data | grep -i whatever

1
  • 1
    This does not address the first part of the question, i.e. "what causes the issue". – Kusalananda Mar 24 '20 at 9:47
0

This can be caused by null bytes in your bash history. Removing lines with null characters may resolve the issue. You can check for them using grep's Perl-regexp mode:

grep -Pa '\x00' .bash_history

This post has suggestions for non-unix systems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.