0

I am on a Dell Inspiron 11 3000 series with an Intel Celeron N3050 processor using integrated Intel HD Graphics (Braswell).The CPU architecture is 64-bit (x86_64). The screen has a 1366 x 768 resolution. The system is UEFI enabled. Fast boot and secure boot are both turned off.

I have recently attempted installing Arch Linux with the systemd bootloader. This is my first time running Arch. There are no other operating systems installed, and I have not installed any graphical environments beyond Xorg. I have installed the xf86-video-intel and xf86-video-vesa graphics drivers.

After selecting the Arch Linux boot option from systemd, the screen goes black shortly into the boot sequence - generally right after the message [ OK ] Starting Flush Journal to Persistent Storage (sometimes just before/after this).

I have tried specifying UXA as the acceleration method in /etc/X11/xorg.conf.d/20-intel.conf but this did not solve the problem. The kernel parameters acpi_osi="Linux", i915.modeset=1, video=SVIDEO-1:d, and video=VGA-1:1280x800 also still resulted in black screens (I also tried video=VGA-1:1366x768, thinking I might have to specify my native resolution, but had no luck).

I am able to reach the console if I boot with either i915.modeset=0 or nomodeset specified in the kernel parameters, but this leads to very poor performance when running X. I would like to be able to boot without these options, if possible.

What can I do to try and fix this issue?

1

Using i915.modeset or nomodeset disables KMS (kernel mode setting), disallowing the kernel to set up the graphics display, and in turn making X.org responsible for doing so.

Make sure you have CONFIG_FRAMEBUFFER_CONSOLE enabled (preferably set to Y) in the kernel. If your kernel has CONFIG_IKCONFIG_PROC enabled, then you can check for framebuffer like this: zcat /proc/config.gz | grep CONFIG_FRAMEBUFFER_CONSOLE

Additional resources

  • Running your given zcat command returned CONFIG_FRAMEBUFFER_CONSOLE=y, CONFIG_FRAMEBUFFER_CONSOLE_DETECT_PRIMARY=y, and CONFIG_FRAMEBUFFER_CONSOLE_ROTATION=y. – SAMM Jan 8 '17 at 18:14
  • Also tried acpi_osi="Linux" and i915.modeset=1 as boot parameters, neither fixed the problem. – SAMM Jan 8 '17 at 18:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.