6

I recently upgraded from Fedora 23 to 25, which seems to have broken my display manager configuration.

I was using lightdm and was able to switch between 3 GUIs running lightdm by just hitting ctrl+alt+Fn, n being the number of the tty. This started lightdm automatically on each tty I had configured.

After the upgrade, lightdm was completely broken. I managed to get it running again by modifying the configuration and changing, I think it was [DefaultSeats] to [Seat:*]. Now it is running, but only on the tty that has exactly the minimum-vt number. So if I set minimum-vt=7, for example it will only run on tty7; the others don't autostart anymore. On tty8-12, I just get a blinking underscore and lightdm doesn't react to the switching according to the logs when running lightdm -d. tty1-6 are normal console ttys.

Output of lightdm --show-config (which composes all configurations and shows the one that is ultimately used to start lightdm):

[LightDM]
 minimum-vt=7
 user-authority-in-system-dir=true
 seats=seat0, seat1, seat2
 minimum-display-number=0

[Seat:*]
 session-wrapper=/etc/X11/xinit/Xsession
 xserver-command=X -background none
 greeter-session=lightdm-gtk-greeter

[Seat:seat0]
vt=7

[Seat:seat1]
vt=8

[Seat:seat2]
vt=8

Unfortunately I couldn't find any documentation on the vt= option but it was working on Fedora 23. I read something about a use-vt= option here. But it seems to be something planned and not yet implemented. Here is another post that about the vt option. I tried this configuration, but maybe I'm missing something.

Apparently lightdm is ignoring both the vt= and use-vt= options. lightdm -d said that it loaded the configuration for seat0 and it didn't matter to which value I set it, the actual vt remained the minimum-vt= value.

I also tried adding -sharevts to the standard xserver-command which left me stuck in the vt that lightdm took me to first. So it may be working like that but I can't switch vt. This may be because of the hard-coded -no-vtswitch option that is automatically passed to the X server, but I'm not sure as I found many configurations in older forum posts that even manually passed that option to X and it was working for them.

I'd like to be able to autostart and switch between the GUIs again. I'm also ok with another display manager. I already tried ssdm, but there doesn't seem to be an option for multiple seats at all.

  • Perhaps not really helpful, but just a side note : do not skip releases when upgrading. – schaiba Jan 7 '17 at 16:17
  • @shaiba Thanks for the tip, I'll keep that in mind. Although I didn't encounter any issues apart from that yet. – rudib Jan 7 '17 at 16:19
  • @Anthon may I consult you as you participated in a post related to this issue? Thank you! – rudib Jan 7 '17 at 18:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.