I have a SUSE Linus and when I run curl it is using a proxy (without any proxy-related parameters passed).

Where can I find the proxy configuration?

I checked the http_proxy/https_proxy environment variables but they are not configured. Also there is no configuration in the /etc/sysconfig/proxy file. Actually I printed the whole environment and found no proxy configuration (i.e. the used proxy host and port) present there.

Is there some other way that curl can read a proxy configuration?

  • Please provide the exact command(s) used and the outputs that makes you believe that curl is using a proxy. – ckujau Jan 7 '17 at 0:49
  • @ckujau I get an error page from the proxy that the host was not found. This is expected because the host is in the internal network and should be called directly. – vap78 Jan 7 '17 at 14:49

Your curl config file may be forcing a proxy even if the environment isn't.

Look for the file ~/.curlrc and see if it has a proxy = .... line in it.

You can also try using curl without a config file: curl -q http://the.site.com and see if you get the same error from the proxy. (The -q must be the first parameter given, or it reads the default config file anyway.)

Lastly, since you have an internal network, is the gateway forcing a proxy? You can't stop that from your machine, network admin will have to fix that.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.