1

Whenever I close my laptop lid, or hit the power button, the machine appears to go to sleep. But when I return later, the machine is still running and taking power. Which has caused my machine to die from power loss when not plugged in. I am also unable to resume from the sleep/hibernation, as I just get a black screen.

I have followed the instructions here

https://wiki.archlinux.org/index.php/Mac#Suspend_and_Hibernate

but the setting in dconf-editor were already set to normal. It says it works out of the box. I have tried the different available options in the power settings but nothing seems to work.Was hoping others might know how to solve this problem.

my file /proc/acpi/wakeup has the following:

$ cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
PEG0      S3    *disabled  pci:0000:00:01.0
PEG1      S3    *disabled  pci:0000:00:01.1
PEG2      S3    *disabled
EC    S4    *disabled  platform:PNP0C09:00
GMUX      S3    *disabled  pnp:00:03
HDEF      S3    *disabled  pci:0000:00:1b.0
RP03      S3    *disabled  pci:0000:00:1c.2
ARPT      S4    *enabled   pci:0000:03:00.0
RP04      S3    *disabled  pci:0000:00:1c.3
XHC1      S3    *enabled   pci:0000:00:14.0
ADP1      S4    *disabled  platform:ACPI0003:00
LID0      S4    *enabled   platform:PNP0C0D:00

and my dconf settings

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.