4

I've a PC with an Intel Wireless 8260 running Debian Unstable. networking.service slows the startup (with systemd) down with 1 minute and ~5 seconds. I'm running version 4.8.15-2 of the Linux kernel with version 20161130-2 of the iwlwifi firmware. After my system has finally started up, the internet is slow and I've to run sudo iw dev wlan set power_save off to make the speed acceptable, but still not the full speed I get on my cheap Windows laptop. The output of sudo dmesg | grep iwl is:

[    4.668210] iwlwifi 0000:01:00.0: enabling device (0000 -> 0002)
[    4.681311] iwlwifi 0000:01:00.0: firmware: failed to load iwlwifi-8000C-24.ucode (-2)
[    4.681313] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-24.ucode failed with error -2
[    4.681326] iwlwifi 0000:01:00.0: firmware: failed to load iwlwifi-8000C-23.ucode (-2)
[    4.681327] iwlwifi 0000:01:00.0: Direct firmware load for iwlwifi-8000C-23.ucode failed with error -2
[    4.695991] iwlwifi 0000:01:00.0: firmware: direct-loading firmware iwlwifi-8000C-22.ucode
[    4.696663] iwlwifi 0000:01:00.0: loaded firmware version 22.361476.0 op_mode iwlmvm
[    4.732100] iwlwifi 0000:01:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x208
[    4.734471] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[    4.735424] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[    4.897671] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[   66.833134] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[   66.833550] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[   66.972299] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled
[   66.972727] iwlwifi 0000:01:00.0: L1 Enabled - LTR Enabled

The output of sudo iwconfig wlan0 is:

wlan0     IEEE 802.11  ESSID:"VFNL-DE1BA0"  
          Mode:Managed  Frequency:2.447 GHz  Access Point: 00:1D:AA:DE:1B:A0   
          Bit Rate=270 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=51/70  Signal level=-59 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:23   Missed beacon:0

How can I make my system startup fast and get the full speed of my internet?

1

1 Answer 1

4

There was a bug report filed against Ubuntu a few years back that said

echo "options iwlwifi 11n_disable=8" | sudo tee -a /etc/modprobe.d/iwlwifi.conf
Would help regain the performance by enabling aggressive tx You will need to reboot or unload and load iwlwifi to see the change

1
  • I had the same thing on deepin linux and now it's resolved. Thanks again! Oct 14, 2018 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.