1

I tried to install ffmpeg on centos 6, but I got some dependency error like this:

Error: Package: ffmpeg-libs-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libhogweed.so.2()(64bit)
Error: Package: libavdevice-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libcdio_paranoia.so.1()(64bit)
Error: Package: ffmpeg-libs-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libgnutls.so.28(GNUTLS_1_4)(64bit)
Error: Package: x265-libs-1.9-1.el7.nux.x86_64 (nux-dextop)
       Requires: libm.so.6(GLIBC_2.15)(64bit)
Error: Package: libavdevice-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libcdio_cdda.so.1()(64bit)
Error: Package: ffmpeg-libs-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libgnutls.so.28(GNUTLS_3_0_0)(64bit)
Error: Package: ffmpeg-libs-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libgmp.so.10()(64bit)
Error: Package: ffmpeg-libs-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libgnutls.so.28()(64bit)
Error: Package: ffmpeg-libs-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: liblzma.so.5(XZ_5.0)(64bit)
Error: Package: ffmpeg-libs-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libx264.so.142()(64bit)
       Available: libx264_142-0.142-20_20140406.2245.el6.x86_64 (atrpms)
           libx264.so.142()(64bit)
       Available: x264-libs-0.142-4.20140423gite260ea5.el7.nux.x86_64 (nux-dextop)
           libx264.so.142()(64bit)
       Available: x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64 (nux-dextop)
           libx264.so.142()(64bit)
       Available: x264-libs-0.142-11.20141221git6a301b6.el7.nux.x86_64 (nux-dextop)
           libx264.so.142()(64bit)
Error: Package: ffmpeg-libs-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libopenjpeg.so.1()(64bit)
Error: Package: libavdevice-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libcdio_cdda.so.1(CDIO_CDDA_1)(64bit)
Error: Package: ffmpeg-libs-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: liblzma.so.5()(64bit)
Error: Package: ffmpeg-libs-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libass.so.5()(64bit)
Error: Package: libavdevice-2.6.8-3.el7.nux.x86_64 (nux-dextop)
       Requires: libcdio_paranoia.so.1(CDIO_PARANOIA_1)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I am using vultr vps as a cloud server and follow this tutorial:

https://www.vultr.com/docs/how-to-install-ffmpeg-on-centos

  • Do you want to download all rpm packages manually for ffmpeg? If you want to install it manually. You can download all rpm packages from rpm.pbone.net.Download it into one folder and run # rpm -Uvh *.rpm.Because You already got all rpm packages list for ffmpeg – supriady Jan 6 '17 at 11:48
  • 2
    What's the problem with yum install ffmpeg ? – Luciano Andress Martini Jan 6 '17 at 11:52
  • I just ran into this also, following instructions from centos.org/forums/viewtopic.php?t=55814 .. without the nux repo installed, yum install ffmpeg gives me 'No package ffmpeg available.'. I have epel, extras and updates repositories enabled (visible via yum repolist). @Rocky Liu did you ever get this working? I really don't want to have to build from source if I don't have to (once I start installing own-build libraries for the dependencies I'm bound to run into dependency hell sometime in the future) – Neek Apr 6 '17 at 9:05
  • Progress. I noticed in my output, and yours above, 'el7' is appearing, despite us both running CentOS 6. It's because the nux repo is selecting el7 packages that lead to the inconsistency. Perhaps you accidentally followed the 'for CentOS 7' part of the vultr.com guide you linked to. I did the same thing, the advice in the forum I linked to above was only for el7, once I used the right repo, and cleaned yum cache (actually rm -rf /var/cache/yum) then yum install ffmpeg resolved el6 packages and there are no conflicts. – Neek Apr 6 '17 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.