0

Following these instructions exactly:

  1. https://ubuntu-mate.community/t/gpar...dows-users/797
  2. https://ubuntu-mate.community/t/inst...lse-method/651 to partition a 1TB SSD and install Ubuntu-Mate off a live USB.

My partitioning is different than the instructions as follows(also see attached image)

1 esp 550MiB
2 root 40 GB
3 home 640 GB
4 swap 128GB

At the blinking cursor, I can either ALT-F4 to boot to UEFI or ESC and I (capital i) or continue to boot to my 2nd SSD with a Windows 10 install.

If I try holding the SHIFT key on reboot I instead see capital GRUB with a blinking cursor on a black screen.

Hitting RETURN takes me to my 2nd SSD with a Win 10 install.

The only change I have made to my UEFI is to disable FastBoot.

Next I tried Boot Repair from a live USB, and attempted to reinstall my grub, but for some reason it did not 'see' my ESP at sda1, only sda and sda2 which is my root partition.

So, probably a mistake, I let it go ahead and install grub in sda2.

After rebooting, same result, blinking cursor.

Next I relaunched gparted from a live USB and reexamined my partitions.

Now I was seeing an error icon on my ESP at sda1, saying it wasn't recognized because I was missing certain files (see attached esp_warning).

I am also getting a warning whenever launching gparted about a discrepancy between Linux and the driver descriptor in regards to physical block size. (attached LibParted_warning)

Question> For my GPT partitioned drive, does it matter what partition flag I have set for my ESP? It was set to 'boot', then I tried 'bios-grub' but neither worked. Results of boot-repair here http://paste.ubuntu.com/23750353/

The Boot Repair results DO seem to indicate a few things wrong. I assume that reinstalling grub with Boot repair AFTER setting my ESP flag to bios-grub may be part of the reason?

And before anyone comments on my swap size
1- storage is relatively cheap.
2- I use my Linux PC primarily for particle simulations in Houdini and got some feedback from Linux-Houdini experts a lot more knowledgeable than I
3- If after several months of use I discover I rarely use that amount, I assume I can easily increase my home partition and reduce swap.

I realize this is a long post but trying to include as much information as possible.

partition libParted warning esp warning

  • Did you try deleting all partitions and then creating a new partition table? – Julie Pelletier Jan 6 '17 at 4:16
  • as a last resort will do but before I need to know what I did wrong in my first attempt. I definitely DID remember to set my UEFI bootloader to my ESP, but perhaps it didn't 'take' for some reason – Bachalo Jan 6 '17 at 12:57
0

I just got my dual boot of Windows 10 (pre-installed on a Dell computer) and Linux mint working. I followed techmint instructions for creating the dual boot for Windows 10 and Linux Mint 18 in UEFI.

After the install the system would only boot to Windows and going into UEFI didn't show any sign of Linux. Changing the boot mode to Legacy Bios mode (It's F12 during boot up on a Dell, but different for each hardware manufacturer) allows the computer to boot into Linux, but there was no sign of Windows.

The solution for me was to find a way to boot into Linux in UEFI mode and then run boot-repair:

  1. Install rEFInd on a USB disk and boot to that disk. The read me in the download shows how to make the disk bootable. I actually created the disk from a linux boot USB drive, but you could do it from Windows too (but I didn't figure that part out). As the instructions say, be very careful to direct the rEFInd .iso file to the proper disk, as you don't want to scramble your hard drive.

  2. Then boot up in UEFI mode (which for me would only boot to Windows) and then boot to the rEFInd USB drive. From the rEFInd menu, select the Linux installation on your hard drive.

  3. Now, booted into Linux from UEFI mode, use apt-get (from the command line) to install, update and run boot-repair. Boot-repair had me make some changes from the command line to uninstall and re-install the GRUB boot loader in the main UEFI section.

From here on out I'm in UEFI mode and GRUB comes up when I boot, where I can select my Linux Mint or Windows installs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.