3

How to disable LAN connection at startup in Debian Jessie? Ido not know what establishes that connection. Is it any configuration file or my wicd that starts on boot. But when I open wicd I can see that connection via the wire is established after system startup. I do not want this connection because the modem connection does not work then. How to disable LAN on boot?

interfaces file:

root@debian:cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
root@debian:/home/gameboy# 
  • 1
    What is in /etc/network/interfaces ? – ivanivan Jan 5 '17 at 19:10
  • I put it into the question – trzczy Jan 5 '17 at 19:41
  • Your network isn't being brought up automatically during boot, so it would be WICD or NetworkManager or whatever your DE is using to do the connectiviity. – ivanivan Jan 5 '17 at 19:45
  • Actually you can disable networking from NetworkManager. Or you can leave LAN connection unconfigure.I also used modem connection.I didnt configure my LAN connection. – supriady Jan 6 '17 at 3:21
  • You can delete lan connection from wicd.You can add it again when you needed lan connection. – supriady Jan 6 '17 at 3:29
3

These two lines define the actions to be applied to the eth0 interface:

allow-hotplug eth0
iface eth0 inet dhcp

The man page for interfaces (man interfaces) will describe it in glorious detail, but essentially, it's saying

  • If we have an eth0 interface, allow it to be defined
  • When we find eth0 bring it up with DHCP

In older versions of Debian you could simply comment out both lines. However, in newer versions this tells other network managers to take control of the interface, so that's not advisable.

Instead, change dhcp to manual, which tells the other network managers that you want control of the interface retained in this file, but that you don't want it brought up automatically:

allow-hotplug eth0
iface eth0 inet manual

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.