3

The master volume keeps changing while I'm listening on youtube music in the browser. The OS is Debian Jessie. I adjusted the volume in the GUI and using the terminal (with "amixer set Master 40%") and it later changed repeatedly regardless the way I've changed it previously. There are no other applications running besides the browser.

1

If pulse audio is the default and applications are changing it, you may need to fix that. Check these two config files for "flat-volumes"

/etc/pulse/daemon.conf 

~/.config/pulse/daemon.conf

If it exists and is not flat-volumes=no, change it to be no. This may solve the issue. I would suggest adding more info...does the volume change when you reboot?, etc

  • The problem persists after reboot. I did not know what other information was relevant and didn't want to fill the question with useless clutter. I've changed the "/etc/pulse/daemon.conf" file by setting "flat-volumes" from "yes" to "no". There was no "~/.config/pulse/daemon.conf" file. Thank you so much for your answer. I would like to give it some time before marking it as correct, since the issue manifests intermittently. – 0ana Jan 5 '17 at 14:35
  • Sorry, this doesn't seem to be the answer. After all this time, the problem showed up again, despite having flat-volumes=no in ~/.config/pulse/daemon.conf and vim /etc/pulse/daemon.conf. The volume gets muted after a random time interval (usually a few seconds) after I change it back to what I want it to be. – 0ana Feb 16 '17 at 8:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.