I have a laptop running hostapd, phpd, and mysql. This laptop uses an Ethernet connection to connect to the internet and acts as a wireless access point for my workplace's wifi devices. After installing some software and reconnecting my Ethernet elsewhere, my "em1" device is no longer present and wirelessly connected devices can no longer reach the internet.

The software I recently installed is: pptp, pptpd, and updated some fedora libraries. I have also recently moved my desk and laptop to another location and thus had to reconnect the Ethernet elsewhere.

Wifi devices no longer have access to the internet. Wirelessly connected devices are able to successfully log into the laptop, showing full strength, correct SSID, and uses the proper password. However, when I tried to connect to a site like google, the request times out.

The device "em1" also no longer appears on my machine. Running: # ifup em1 will give me the following output: ERROR : [/etc/sysconfig/network-scripts/ifup-eth] Device em1 does not seem to be present, delaying initialization. And running: # dhclient em1 has the following output: Cannot find device "em1"

When I run # dmesg|grep renamed, I get the following: renamed network interface eth0 to p4p1. I've tried to connect to the internet through p4p1 and was successful. However, my wireless devices connected to my laptop are no longer able to connect to the internet.

I have uninstalled pptp and pptpd using # yum erase ... but the problem still persists.

To install pptp I used: # yum install pptp

To install pptpd I did the following:

# rpm -Uvh http://poptop.sourceforge.net/yum/stable/fc15/pptp-release-current.noarch.rpm
# yum install pptpd

To update my fedora libraries I used:

# yum check-update
# yum update


Running # route produces the following results:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         UG    0      0        0 p4p1     *        U     0      0        0 p4p1    *        U     0      0        0 wlan0

1 Answer 1


I opted to solve this issue by starting from scratch.

I installed Fedora 17, hostapd, dnsmasq, iptables, and community drivers.

  • The drivers I used were compatible with my hardware and the instructions for installing them are here: http://linuxwireless.org/en/users/Drivers/b43.
  • dnsmasq was used to host a dhcp server which will assign IPs to connected devices.
  • iptables was used to enable NAT forwarding through my ethernet interface.
  • hostapd was used to manage the wifi connection and security.

The following is a script I made to start a working access point:

echo 1 > /proc/sys/net/ipv4/ip_forward

# Clear iptables Rules
iptables -F
iptables -t nat -F

# iptables Rules
iptables -A FORWARD -d -o wlan0 -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A FORWARD -s -i wlan0 -j ACCEPT
iptables -t nat -A POSTROUTING -o p4p1 -j MASQUERADE

# Set wlan0 IP
ip addr add broadcast dev wlan0
ip link set wlan0 up

# Set DHCP
dnsmasq -C /dev/null >/dev/null 2>&1 --listen-address= --dhcp-range=,,12h

# hostapd
hostapd /etc/hostapd/hostapd.conf

The content of hostapd.conf is the following:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .