0

When I try to run the wget command on http urls I get this error message:

ERROR: The certificate of `url' is not trusted.
ERROR: The certificate of `url' hasn't got a known issuer.
4

If you are using Debian or Ubuntu operating system please install the package

$ sudo apt-get install ca-certificates

If you don't care about checking the validity the certificate use --no-check-cetificate:

$ wget --no-check-certificate https://download/url

NOTE: Second option not recommended because of possibility to man-in-the-middle attack.

  • Im using kali linux 2.O – Mordechai Hadad Jan 5 '17 at 11:08
  • Its telling me: Bus Error E: Sub-process /usr/bin/apt-listchanges --apt – Mordechai Hadad Jan 5 '17 at 16:36
1

Per TFM for wget use the

--no-check-certificate

option.

"Don't check the server certificate against the available certificate authorities. Also don't require the URL host name to match the common name presented by the certificate."

0

"sudo apt-get install ca-certificates" didn't fix my issue still says its untrusted i just installed this same script an hour ago but i did a clean install of kali in windows 10 from the app store an now keeps telling me its untrusted

  • In this case, ENSURE you CAN trust the site! If you can, AND ONLY IF YOU CAN, you retrieve the certificate with your browser, for example. You need the CA, which is the top-level certificate in teh certificate path in PEM format. Copy your certificate in PEM format (the format that has ----BEGIN CERTIFICATE---- in it) into /usr/local/share/ca-certificates and name it with a .crt file extension. – thecarpy Jun 14 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.