3

My desktop has lost wireless connectivity and I strongly suspect a hardware issue, but I would like to know how I can confirm that that is the problem before I buy a replacement.

My reasons for thinking this are:

  • My NIC was a standard size, but I have a low profile case so, as a bodge, I cut the metal bracket. This worked fine, but it's never felt like it was seated properly, so may have died due to my own miserly stupidity
  • I use wicd-curses to connect to my network and it no longer detected any SSIDs.
  • running sudo ifconfig wlan0 up returns SIOCSIFFLAGS: Connection timed out
  • running iw dev shows my device details
  • running sudo ip link set wlan0 up returns RTNETLINK answers: Connection timed out
  • dmesg gives:

    iwlwifi 0000:01:00.0: Failed to load firmware chunk!
    iwlwifi 0000:01:00.0: Could not load the [0] uCode section
    iwlwifi 0000:01:00.0: Failed to start INIT ucode: -110
    iwlwifi 0000:01:00.0: Failed to run INIT ucode: -110
    

I've exhausted my limited knowledge and Google searching from my phone isn't leading me anywhere. I'm really not familiar with this stuff, so any background info to help me understand what's going on here is very much appreciated!

OS: Xubuntu 16.04 (relatively recently upgraded from 14.04)
Kernel: 4.4.0-47

Edit: I found the solution to my lost connectivity, but I still don't know why. I am therefore leaving this question here in the hope that someone can answer my original question: how can I debug this kind of problem?

2 Answers 2

3

The solution to my actual problem of lost connectivity has been solved thanks to an answer on the AskUbuntu StackExchange. The solution was to disable power management as follows:

sudo iwconfig wlan0 power off

I did not need to disable the 802.11n extension.

1

After recent update of OpenSUSE 15.3, my ASUS ROG laptop with Intel(R) Wireless-AC 9560 adapter started suddenly loosing WiFi device.

To find out what was the reason (and wireless adapter model) I used following command:

sudo dmesg | grep iwl

First I tried to remove and then install wifi module as described in https://askubuntu.com/questions/271387/how-to-restart-wifi-connection

sudo modprobe -r iwlmvm
sudo modprobe -r iwlwifi
sudo modprobe iwlwifi
sudo modprobe iwlmvm

But after a couple of restarts the computer started hanging with caps lock button light blinking.

Thanks to Mike, turning off power management for wifi let me having the system that does not hang after a couple of minutes after reboot:

sudo iwconfig wlan0 power off

If your wifi currently disabled, you'll need to combine both methods mentioned above.

I also tried downloading latest ucode (46 version) from Intel's website https://www.intel.com/content/www/us/en/support/articles/000005511/wireless.html and placing into /lib/firmware folder. Also move somewhere the firmware that is in default package to a backup folder.

cd /lib/firmware
mv ./iwlwifi-9000-pu-b0-jf-b0-46.ucode.xz ~/
wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/iwlwifi-9000-pu-b0-jf-b0-46.ucode

After this reload iwlwifi module as described above or reboot.

But this method and turning off power management helped only until my laptop got slept for a night.

So I started deleting firmware versions one after another until I got stable system with power management on, here is what is final solution I use currently (run as root):

su root
# enter password
cd /lib/firmware
mv ./iwlwifi-9000-pu-b0-jf-b0-46.ucode.xz ~/
mv ./iwlwifi-9000-pu-b0-jf-b0-43.ucode.xz ~/
mv ./iwlwifi-9000-pu-b0-jf-b0-41.ucode.xz ~/
mv ./iwlwifi-9000-pu-b0-jf-b0-38.ucode.xz ~/
modprobe -r iwlmvm
modprobe -r iwlwifi
modprobe iwlwifi
modprobe iwlmvm

This gave a bit of calm time, but yet not helped.

So then in addition to downgrading firmware I made a combination of what is suggested here:

su root
# enter password
cd /lib/firmware
mv ./iwlwifi-9000-pu-b0-jf-b0-46.ucode.xz ~/
mv ./iwlwifi-9000-pu-b0-jf-b0-43.ucode.xz ~/
mv ./iwlwifi-9000-pu-b0-jf-b0-41.ucode.xz ~/
mv ./iwlwifi-9000-pu-b0-jf-b0-38.ucode.xz ~/
cat <<EOF > /etc/modprobe.d/99-iwlwifi.conf
blacklist hp_wmi
blacklist intel_ips
options usbcore autosuspend=1
options i915 modeset=1
options iwlwifi swcrypto=0
options iwlwifi power_save=0
options iwlwifi uapsd_disable=1
options iwlmvm power_scheme=1
EOF
modprobe -r iwlmvm
modprobe -r iwlwifi
modprobe iwlwifi
modprobe iwlmvm
iwconfig wlan0 power off

So far for 3 days I experience no problems, but I added it to the keyboard shortcut so I could have WiFi back after next bad update.

After some time started experiencing problems again, so tried to install kernel-firmware-iwlwifi version 20211030.

After update to OpenSuse Leap 15.3.2 my script is:

cat <<EOF > /etc/modprobe.d/99-iwlwifi.conf
options usbcore autosuspend=0
options i915 modeset=1
options iwlwifi swcrypto=0
options iwlwifi power_save=0
options iwlwifi uapsd_disable=1
options iwlmvm power_scheme=1
EOF

modprobe -r iwlmvm
modprobe -r iwlwifi
modprobe iwlwifi
modprobe iwlmvm

iwconfig wlan0 power off

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.