0

I have just installed Google Chrome (55.0.2883.87-1) onto my Kali box (4.8.0-kali2-amd64).

I pulled it from the official chrome download site, i installed pre-reqs with apt-get install -f and then installed with dpkg -i google-chrome-stable_current_amd64.deb

The installation runs successfully, but as soon as I try and execute either via command line I get an illegal instruction.

Syslog looks like this:

tail -f /var/log/syslog

Jan  4 15:14:51 MB00364KALI kernel: [  155.645161] traps: chrome[2935] trap invalid opcode ip:5576a72aa639 sp:7fffed65aae0 error:0 in chrome[5576a66a9000+6612000]
Jan  4 15:14:51 MB00364KALI kernel: [  155.646399] traps: chrome[2926] trap invalid opcode ip:5578efdfbafb sp:7fff5bc390b0 error:0 in chrome[5578ee433000+6612000]

I tried uninstalling, doing an apt update, upgrade and reboot and then rebooted but I encounter the same issue.

Any pointers?

  • digitz.org/blog/… – user8779 Jan 4 '17 at 15:37
  • Thanks @arochester , this works. As Firefox worked under root, I just expected Chrome to do so. Another issue arose out of this which was the user didn't have ability to use the display which was fixed by running 'export DISPLAY=":0.0"' – iainpb Jan 4 '17 at 16:09
  • 1
    With a kind of tweaking you can make it work under root account either by gksu -u username google-chrome-stable or by these tweaks: unix.stackexchange.com/questions/175967/… – George Vasiliou Jan 8 '17 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.