2

The software I'm using is only supported by CentOS 7.2.

I tried

sudo yum --releasever=7.2 update

and get

Cannot find a valid basurl for repo: base/7.2/x86_64.

With

sudo yum update

takes me to 7.3

  • 1
    try --releasever=7.2.1511 – rAlen Jan 4 '17 at 10:10
5

CentOS 7.2 actual version is 7.2.1511 and uses this URL

http://mirror.centos.org/centos/7.2.1511/os/x86_64/

Try yum --releasever=7.2.1511 update

You can also try to edit /etc/yum.repos.d/CentOS-Base.repo, and change baseurl to

http://mirror.centos.org/centos/7.2.1511/os/x86_64/

instead of

http://mirror.centos.org/centos/$releasever/os/$basearch/
  • I changed the baseurls as said and commented out the mirrorlist. I'm getting Damaged repomd.xml . OK yum clean all fixed that. – OrigamiEye Jan 4 '17 at 11:33
  • The full edit, repeated under [base], [updates], and [extras] [base] name=CentOS-$releasever - Base #mirrorlist=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os&infra=$infra baseurl=http://mirror.centos.org/centos/7.2.115/os/x86_64/ gpgcheck=1 gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-7 then yum clean all – OrigamiEye Jan 4 '17 at 11:47
  • At the moment mirror.centos.org/centos/7.2.1511/readme contains the following text: This directory (and version of CentOS) is deprecated. For normal users, you should use /7/ and not /7.2.1511/ in your path. ... If you know what you are doing, and absolutely want to remain at the 7.2.1511 level, go to http://vault.centos.org/ for packages. – haggai_e Jun 28 '17 at 12:05
  • They archived it, you can access it at vault.centos.org/7.2.1511 – rAlen Jun 29 '17 at 10:02
1

Below line worked for me:-

1) vi /etc/yum.repos.d/CentOS-Base.repo

2) Replace baseurl:- baseurl=http://vault.centos.org/7.2.1511/os/x86_64/

3) yum --releasever=7.2.1511 update --skip-broken

and finally check -- cat /etc/redhat-release

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.