0

My notebook's keyboard suddenly went all paranormal activity like weird. Two keys, minus and asterisk from the num pad were being pressed and held at random moment when typing something somewhere. I then removed the button and the small rubber that makes the contact with the board. Few days later, the return started to suffer the same thing. Everything I selected with one click was being deleted and, when in a text editor software or anything that have an input field, all being erased, just like holding the return or backspace key. I also noticed few times the dot key.

I learned about xinput to disable the keyboard and these inconvenient events, then using an external one. But it turns out that sometimes when turning the computer of, some mysterious key is also pressed, making the splash screen of my system and a screen showing what's happening behind the scenes rapidly toggle between each other. I suppose it's f2, because you can do it in Ubuntu pressing f2. Also, when turning the computer on. When this is happening during these moments, I cannot log-in nor turn the computer off simply by waiting.

I want to permanently disable the keyboard, be it when turning the computer on and off, and never use it again. I didn't find anything on BIOS or a way to do it with xinput. I'm afraid I'll have to open the computer and manually cut some wire for it to happen, but it is worthy the shot asking online, hoping for an easier solution. Much appreciated.

  • 1
    Can't you just unplug the keyboard? It sounds like your keyboard's dying. – Bratchley Jan 3 '17 at 17:13
  • 1
    @Bratchley It's a laptop. – Kusalananda Jan 3 '17 at 18:25
  • Yes, I am sorry, it's a laptop. – gamofe Jan 4 '17 at 1:32
0

Use i8042.nokbd kernel parameter in your grub.cfg.

  • Can you explain to me how to do it exactly? I found the file, but I'm not sure what to do. Thank you. – gamofe Jan 4 '17 at 1:36
  • (I'm using Devuan, which is essentially Debian) Open /etc/default/grub as root and change the GRUB_CMDLINE_LINUX_DEFAULT variable to include i8042.nokbd. It will look somewhat like this: GRUB_CMDLINE_LINUX_DEFAULT="quiet i8042.nokbd". Save the file and then run (as root) in the terminal: update-grub. Restart your laptop. – undostres Jan 4 '17 at 2:11
  • 2
    @undostres, please write an answer. – gamofe Jan 4 '17 at 7:36
  • IMO my comment it's not an answer to your original question. It could expand @ipor answer (which I don't know if its correct). – undostres Jan 5 '17 at 2:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.