1

My Laptop has 3 Windows 7, and 2 Linux distributions, Ubuntu & Mint.

When booting the Laptop, Grub would show up with Mint as my first option, Ubuntu as the second, and Windows EFI Bootloader as the third.

When selecting the third option, a Windows bootloader would be prompted with my 3 options of Windows.

Also, it's worth mentioning that I have both an SSD and a HDD and the operating systems and the boot info are installed in the SSD, in GPT format (not MBR anymore). Thus, the Windows are installed as EFI, whereas the Linuxes are not.

Recently I removed my SSD and plugged another one, just to erase all data. I booted a live CD of Ubuntu and ran a Secure Wipe on the new SSD. Everything went smoothly. After that, I plugged my original SSD back. Interestingly, Windows bootloader was appearing first with the 3 options of Windows. To use Linux, I have to hit Esc, then the BIOS let me choose a device from the boot list,

enter image description here

then I have to select the SSD device (Internal HDD: Crucial_...), and Ubuntu's grub version appears (The purple one, whereas the original was black & white which I installed from Mint)

enter image description here

I figured the problem was in the BIOS that was booting Windows's bootloader first, so I checked it

enter image description here

As you can see, EFI appears at the top, apart from "Boot Priority". "Internal HDD: Crucial_..." is correctly set at the top of "Boot Priority", but somehow EFI is loading first. I cannot, through BIOS, set the EFI to a low priority.

As everything was normal before, and I didn't change BIOS settings, I cannot understand what happened. Also, it's very curious that it seems to have affected my cookies. I use Google Chrome, and I had to re-login into my e-mail, facebook, etc accounts. As far as the computer is concerned, a device was replaced, and then replaced back in. No settings were changed by me, so what could have happened and how can I change things back to how they were before (grub booting first)?

1

In my experience BIOS is a picky bitch and often choose to see or not to see a given MBR or partition signature, act like if it wasn't there. Quite possible that it don't like anything from your new SSD partition.

You may try to disable EFI in the BIOS and see whether your non-EFI boot starts at all or not. If it does, GRUB can pull up your EFI later. (And in this case your system will work but we never know why EFI got priority; it's a BIOS mood change.)

If disabling EFI results a non-bootable system then your BIOS decided to dislike your MBR. (I can't help that - I had a month-long discussion back in the days with intel about a similar problem and the result was "they do not support non-windows mbrs, and they don't have the faintest idea about what the BIOS dislike there". Sometimes copying an old and working MBR then changing it works.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.