2

My friend just installed Peppermint 7 (based on Ubuntu 16.04, with xfce) on his laptop. Arabic is installed on the system, he's trying to use the Saudi Arabian version.

I'd like to leave the language as English but be able to switch the keyboard to arabic.

Xfce keyboard switcher doesn't seem to be working, doesn't detect arabic, right clicking it and trying to select its settings won't work either.

Arabic option is grayed in keyboard layout

sudo echo '@setxkbmap -option grp:alt_shift_toggle "us,ar"' | sudo tee -a /etc/xdg/lxsession/Peppermint/autostart

and

sudo echo '@setxkbmap -option grp:alt_shift_toggle "en,ar"' | sudo tee -a /etc/xdg/lxsession/Peppermint/autostart

Doesn't seem to work either. Personally I have never installed a secondary language on my PC and the solutions I tried are the ones posted on peppermint's forum. I don't know what else to try

1

Issue solved by following instructions from here

Basically it seems that I needed to install this

https://launchpad.net/~peppermintos/+archive/ubuntu/p7-dev/+files/xfce4-settings_4.12.0-2ubuntu1+peppermint1_amd64.deb

Since the guy on the forum claims that the newer versions won't work. After doing that I was able to add arabic

Click the Add button (+) .. highlight the "Keyboard Layouts" item, and click the "Add" button. (You'll see a flag appear by your clock) click the "Close button.

And I had to restart the PC. Perhaps a log out / log in would work but I did a restart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.