0

I have two conky windows that start with xinit. One uses the old syntax and works perfectly. The other uses the new syntax and works perfectly when started from the terminal. However, when started with xinit, the window using the new syntax appears above all other windows I open. If I save the configuration file o trigger conky to restart, it appears below normal windows as expected.

Conky config using new syntax:

conky.config = {
  alignment =  'bottom_left',
  background = false,
  border_width =  1,
  cpu_avg_samples =  2,
  default_color =  'white',
  default_outline_color = 'black',
  default_shade_color = 'black',
  draw_borders =  false,
  draw_graph_borders =  false,
  draw_outline =  false,
  draw_shades =  false,
  use_xft =  true,
  font = "Fira Sans",
  gap_x = 30,
  gap_y = 69,
  border_inner_margin = 20,
  net_avg_samples =  2,
  no_buffers =  true,
  out_to_console =  false,
  out_to_stderr =  false,
  extra_newline =  false,
  own_window =  true,
  own_window_type = 'override',
  own_window_class =  Conky,
  own_window_argb_visual =  true,
  own_window_argb_value =  200,
  own_window_hints =  undecorated,below,sticky,skip_taskbar,skip_pager,
  stippled_borders =  0,
  update_interval =  1.0,
  uppercase =  false,
  text_buffer_size =  1024,
  double_buffer =  true,
  show_graph_scale =  false,
  show_graph_range =  false,
  draw_graph_borders =  false,
  lua_load = "/home/marcel/.dotfiles/conky/mpd.lua",
}

conky.text = '${texeci 10 artwork 2>&1 > /dev/null}${lua main}'

.xinitrc:

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
    for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
        [ -x "$f" ] && . "$f"
    done
    unset f
fi

conky -d -c ~/.dotfiles/conky/mpd.conky &
conky -c ~/.dotfiles/conky/system.conky &
compton -b --config ~/.dotfiles/compton/compton.conf &
dunst &
exec startxfce4

uname -a:

Linux Hermes 4.8.13-1-ARCH #1 SMP PREEMPT Fri Dec 9 07:24:34 CET 2016 x86_64 GNU/Linux

pacman -Q | grep conky:

conky 1.10.6-1

I have tried with every setting for own_window_type and background and with and without the -d options. Nothing seems to work.

  • As the new config I think you should use lua syntax, i.e. settings are separated by commas, and so you should probably quote the values such as those for own_window_hints. – meuh Jan 2 '17 at 18:19
  • Are you saying to put quotes around each value in window_hints or quotes around the whole string? Sorry not at my computer can't test it. – Marcel Jan 2 '17 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.