1

I have the same problem as reported at https://ask.fedoraproject.org/en/question/73766/fedora-22-not-using-newer-kernal-after-dnf-update/
NOTE: the answers to that posting are not addressing the poster's question, which I'll reformulate as follows:

When I try to update to a newer kernel, i.e. from 4.5.5-300.fc24.x86_64 to 4.8.15-200.fc24.x86_64, the install succeeds but the vmlinuz-4.8.15-200.fc24.x86_64 file doesn't show up in /boot. Note that /lib/modules contains the 4.8.15-200.fc24.x86_64 modules, but the kernel isn't copied into /boot. I've tried also:

dnf -y reinstall kernel-4.8.15-200.fc24

with the following output:

Last metadata expiration check: 0:13:30 ago on Sun Jan  1 14:39:27 2017.
Dependencies resolved.
================================================================================
 Package        Arch           Version                    Repository       Size
================================================================================
Reinstalling:
 kernel         x86_64         4.8.15-200.fc24            updates          76 k

Transaction Summary
================================================================================

Total download size: 76 k
Downloading Packages:
kernel-4.8.15-200.fc24.x86_64.rpm                80 kB/s |  76 kB     00:00    
--------------------------------------------------------------------------------
Total                                            38 kB/s |  76 kB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Reinstalling: kernel-4.8.15-200.fc24.x86_64                               1/2 
  Erasing     : kernel-4.8.15-200.fc24.x86_64                               2/2 
  Verifying   : kernel-4.8.15-200.fc24.x86_64                               1/2 
  Verifying   : kernel-4.8.15-200.fc24.x86_64                               2/2 

Reinstalled:
  kernel.x86_64 4.8.15-200.fc24                                                 

Complete!

But still no /boot/vlimuz-4.8.15-200.fc24.x86_64 file. Note that /boot is in a filesystem with 190 GB of free space. I also tried dnf clean metadata and dnf clean all, but that made no difference.
NOTE also the very small size of the kernel rpm file. Broken repo file? Here are my fedora repo files in /etc/yum.repos.d

-rw-r--r-- 1 root root 1253 Aug 13 07:44 fedora.repo
-rw-r--r-- 1 root root  689 Aug 13 07:44 fedora-cisco-openh264.repo
-rw-r--r-- 1 root root 1270 Aug 13 07:44 fedora-updates.repo
-rw-r--r-- 1 root root 1328 Aug 13 07:44 fedora-updates-testing.repo
  • Did you restart the machine to see if the change was effective? Is it possible that it simply put the file elsewhere? – Julie Pelletier Jan 1 '17 at 21:06
  • What's your full listing of /boot? (ls -la /boot/.) – Julie Pelletier Jan 1 '17 at 21:19
  • @Gordon,This kernel package was not correct.Did you see the size of kernel package (76KB)?. You can try to download it manually from rpm.pbone.net for fc24. – supriady Jan 2 '17 at 3:39
  • Julie: here is the output of ls -la /boot: – Gordon Jan 5 '17 at 19:59
  • Please don't recommend downloading things from rpm.pbone.net. There's literally no telling what you might get. Use a Fedora Mirror. – mattdm Jan 6 '17 at 14:14
1

Try rpm -ql kernel. You will see (contains no files) (possibly multiple times if you have multiple kernels installed). For the past few releases, that's just a "meta package" which pulls in kernel-core and kernel-modules. That's so you can just install kernel-core, if all you need is a minimal kernel to boot in a virtualized environment.

I'm not quite sure how you have the kernel`` package installed without the correspondingkernel-core`, but I'm pretty sure that's what's causing what you are seeing now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.