I'm struggling with very poor wireless performance on a Fedora 25 setup running kernel 4.8.15-300.fc25.x86_64.

When downloading anything via wget, I get like 5Kb/s, and downloads usually stop. If I happen to launch the following ping command in bash while trying to download, performance is fine (about 1Mb/s).

ping google.fr -i .05

As far as I tested, I can surf on internet with some 3-5 seconds lag between pages, which disappears if I use that ping command.

Wifi driver is iwlwifi, firmware is installed even if dmesg complains:

[    4.225476] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-24.ucode failed with error -2
[    4.225484] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7265D-23.ucode failed with error -2
[    4.226742] iwlwifi 0000:02:00.0: loaded firmware version 22.361476.0 op_mode iwlmvm

According to bugzilla (see https://bugzilla.redhat.com/show_bug.cgi?id=1400269), this shoudln't be an issue.

I manage my own AP (TPLink EAP 110) where I tried to change channel, disabling 802.11n, changing channel width, nothing helps.

The laptop I have the wireless issues with also has a Win10 dualboot. Wifi performance on Win10 is normal.

I can imagine that at some point, the ping forces a keep alive or something (not a wireless specialist speaking).

I have no clue how to get around this. Any ideas please ?

  • It's nice to know that I am not the only one experiencing this issue. I also have those same error messages in dmesg. I am getting single- and double-digit kb speeds when I perform a dnf update. I am running Fedora 25 on a System 76 Lemur with 16GB, and kernel 4.8.15-300.fc25.x86_64. I think there may have been a bad driver update. – David Paige Jan 7 '17 at 3:55
  • What wireless card do you have ? Also, can you check if fast pinging some ip like above resolves your speed issue ? – deajan Jan 8 '17 at 10:06
up vote 0 down vote accepted

Well in my case, I've tried disabling 802.11n, tried other iwl-7265D firmwares. At the end of the day, disabling power management did the trick with iwconfig wlan0 power off. Seems to be a big issue with intel cards and iwlwifi drivers.

Rendering this permanent is done by creating the following file in /etc/NetworkManager/dispatcher.d/02-wlan-power

#!/bin/sh
IF=$1
STATUS=$2

IFACES=$(iwconfig 2> /dev/null | grep "802.11" | awk '{print $1}')
for iface in $IFACES; do
    if [ "${IF}" = "${iface}" ] && [ "${STATUS}" = "up" ]; then
        iwconfig ${iface} power off
        logger "${iface}: turning off powersave mode to prevent constant reconnections"
    fi
done

Don't forget to chmod 755 that file. Rebooting should do the trick.

  • I tried iwconfig power off on my wireless adapter, and it didn't make any difference. It's a fairly recent problem, within the last couple of weeks I think. – David Paige Jan 7 '17 at 4:05
  • What's your iwconfig output after the command ? Also, do you have control over your wireless AP ? – deajan Jan 8 '17 at 10:25

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.