0

I have been trying in vain to get the discrete video card to work. I have tried applying all of the nvidia drivers listed in Driver Manager here:
enter image description here
But after a reboot, all I'll get is a black screen with a cursor, which requires me to reconfigure my Xorg. After doing a startx at the end of this reconfiguration step, the desktop graphic interface will come back with a message that Cinnamon has crashed and is currently in fallback mode. I can only then revert things back to their normal states by enabling the nouveau driver :(. I have also updated my kernel to 4.8.0-32-generic, but again nothing changed.

How can I get the discrete video card to work?

Edit: After deleting some PPA with the Software Sources GUI, my Driver Manager looks like this Driver Manager after PPA deleted

7
  • First of all remove your ppa I assume it's launchpad.net/~ricotz/+ppa-packages?start=75&batch=75 with ppa-purge.
    – user192526
    Commented Jan 1, 2017 at 10:48
  • I removed my ppa from Software Sources and reran Driver Manager. Now nvidia-367 shows up as "recommended". Selecting it still causes Cinnamon to crash as before. :( Commented Jan 1, 2017 at 20:24
  • Did you remove the ppa with ppa-purge? If not that is a problem, because the packages from there stay's in your system.
    – user192526
    Commented Jan 1, 2017 at 21:09
  • I know this is a dumb question but how do I find which ppa to remove with ppa-purge? Commented Jan 1, 2017 at 21:21
  • Please see photo of updated Driver Mananger in the edited question. Commented Jan 1, 2017 at 21:38

1 Answer 1

0

First add the ppa again, or it will not work. I think it was this If yes, easier command

sudo ppa-purge -o xorg-edgers

sudo apt update && sudo apt install nvidia-361

Don't be confused, this is the Meta-package for nvidia-367

According to nvidia-page supports the driver your card and it is no beta.

3
  • So I ran sudo add-apt-repository ppa:graphics-drivers/ppa and sudo add-apt-repository ppa:xorg-edgers/ppa, then sudo apt-get update before using ppa-purge to remove them. Then doing sudo apt update && sudo apt install nvidia-361 followed by a reboot again resulted in a black screen with a non-blinking cursor with the only difference being that the Mint start-up sound could now be heard. Doing sudo Xorg - configure and sudo cp xorg.conf.new /etc/X11/xorg.conf again causes Cinnamon to crash. Switching back to nouveau lands me in software-rendering mode... :| How do I get out of this? Commented Jan 2, 2017 at 20:33
  • sudo apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core seems to have helped me get rid of the "software-rendering" mode message. :| Commented Jan 2, 2017 at 20:48
  • Still haven't been able to get this card to be recognized by Mint... Sad :( Commented Mar 31, 2017 at 23:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .