I changed from 32bit to 64bit and i cant install anything. As soon as i installed the OS i used apt-get update and apt-get upgrade. Now everything i try to install i get the following error.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
wine is already the newest version (1.8.5-1).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 gcc-6-multilib : Depends: libc6-dev-i386 (>= 2.11) but it is not going to be installed
 libc6-dev-x32 : Depends: libc6-dev-i386 (= 2.24-8) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Anything i try to install.

Examples: apt-get install wine, apt-get install firmware-iwlwifi

I am very new to unix.

  • You still have links to i386 stuff in your apt lists. Either that, or your apt preferences are still set to want i386 rather than amd64. – Shadur Dec 30 '16 at 21:13
  • "f you are unfamiliar with Linux generally, if you do not have at least a basic level of competence in administering a system, if you are looking for a Linux distribution to use as a learning tool to get to know your way around Linux, or if you want a distro that you can use as a general purpose desktop installation, Kali Linux is probably not what you are looking for." - docs.kali.org/introduction/should-i-use-kali-linux – user8779 Dec 30 '16 at 21:34
  • Run apt-get dist-upgrade – defalt Jan 2 '17 at 12:35

Have you tried apt-get -f install?

If you check man apt-get You will find

 -f, --fix-broken
   Fix; attempt to correct a system with broken dependencies in place. This
   option, when used with install/remove, can omit any packages to permit APT
   to deduce a likely solution. If packages are specified, these have to
   completely correct the problem. The option is sometimes necessary when
   running APT for the first time; APT itself does not allow broken package
   dependencies to exist on a system. It is possible that a system's dependency
   structure can be so corrupt as to require manual intervention (which usually
   means using dselect(1) or dpkg --remove to eliminate some of the offending
   packages). Use of this option together with -m may produce an error in some
   situations. Configuration Item: APT::Get::Fix-Broken.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.