0

This question is an exact duplicate of:

I have Kali Linux installed on VMWare but I do not have any sound.

This is what I get when I run lspci

00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 01)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 01)
00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 08)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:07.7 System peripheral: VMware Virtual Machine Communication Interface (rev 10)
00:0f.0 VGA compatible controller: VMware SVGA II Adapter
00:10.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 01)
00:11.0 PCI bridge: VMware PCI bridge (rev 02)
00:15.0 PCI bridge: VMware PCI Express Root Port (rev 01)
00:15.1 PCI bridge: VMware PCI Express Root Port (rev 01)
00:15.2 PCI bridge: VMware PCI Express Root Port (rev 01)
00:15.3 PCI bridge: VMware PCI Express Root Port (rev 01)
00:15.4 PCI bridge: VMware PCI Express Root Port (rev 01)
00:15.5 PCI bridge: VMware PCI Express Root Port (rev 01)
00:15.6 PCI bridge: VMware PCI Express Root Port (rev 01)
00:15.7 PCI bridge: VMware PCI Express Root Port (rev 01)
00:16.0 PCI bridge: VMware PCI Express Root Port (rev 01)
00:16.1 PCI bridge: VMware PCI Express Root Port (rev 01)
00:16.2 PCI bridge: VMware PCI Express Root Port (rev 01)
00:16.3 PCI bridge: VMware PCI Express Root Port (rev 01)
00:16.4 PCI bridge: VMware PCI Express Root Port (rev 01)
00:16.5 PCI bridge: VMware PCI Express Root Port (rev 01)
00:16.6 PCI bridge: VMware PCI Express Root Port (rev 01)
00:16.7 PCI bridge: VMware PCI Express Root Port (rev 01)
00:17.0 PCI bridge: VMware PCI Express Root Port (rev 01)
00:17.1 PCI bridge: VMware PCI Express Root Port (rev 01)
00:17.2 PCI bridge: VMware PCI Express Root Port (rev 01)
00:17.3 PCI bridge: VMware PCI Express Root Port (rev 01)
00:17.4 PCI bridge: VMware PCI Express Root Port (rev 01)
00:17.5 PCI bridge: VMware PCI Express Root Port (rev 01)
00:17.6 PCI bridge: VMware PCI Express Root Port (rev 01)
00:17.7 PCI bridge: VMware PCI Express Root Port (rev 01)
00:18.0 PCI bridge: VMware PCI Express Root Port (rev 01)
00:18.1 PCI bridge: VMware PCI Express Root Port (rev 01)
00:18.2 PCI bridge: VMware PCI Express Root Port (rev 01)
00:18.3 PCI bridge: VMware PCI Express Root Port (rev 01)
00:18.4 PCI bridge: VMware PCI Express Root Port (rev 01)
00:18.5 PCI bridge: VMware PCI Express Root Port (rev 01)
00:18.6 PCI bridge: VMware PCI Express Root Port (rev 01)
00:18.7 PCI bridge: VMware PCI Express Root Port (rev 01)
02:00.0 USB controller: VMware USB1.1 UHCI Controller
02:01.0 Ethernet controller: Intel Corporation 82545EM Gigabit Ethernet Controller (Copper) (rev 01)
02:02.0 Multimedia audio controller: Ensoniq ES1371/ES1373 / Creative Labs CT2518 (rev 02)
02:03.0 USB controller: VMware USB2 EHCI Controller

I installed libasound2 and alsa-utils and alsa-oss and then rebooted, still no sound.

sudo apt-get install libasound2 alsa-utils alsa-oss

I ran the following command, rebooted and still no sound

systemctl --user enable pulseaudio && systemctl --user start pulseaudio

I ran the following command and rebooted, still no sound

curl -s https://raw.githubusercontent.com/nu11secur1ty/pulseaudio/master/pulseaudio.sh | bash

I installed GNOME ALSA and this is how it looks

enter image description here

And this is the VM settings of the sound card

enter image description here

marked as duplicate by dirkt, user88036, countermode, Romeo Ninov, RalfFriedl Sep 25 '18 at 16:56

This question was marked as an exact duplicate of an existing question.

  • Does the sound work on the host? What is the host's OS? – Julie Pelletier Dec 30 '16 at 18:38
  • Yes, the sound works on the host. Windows 10. – Halnex Dec 30 '16 at 18:43
  • you should select Connected and Connect at power on. – GAD3R Dec 30 '16 at 22:19
  • @GAD3R I already tried that, it doesn't help and it automatically unchecks after I check the "Connected" checkbox. – Halnex Dec 30 '16 at 22:55
0

According to the official website you can configure ALSA sound card on VMware as follows:

  1. Select the virtual machine and select VM > Settings.
  2. On the Hardware tab, select Sound Card.
  3. Select Connected and Connect at power on.
  4. Select Specify host sound card and select the ALSA sound card.
  5. If the ALSA sound card does not appear in the list, use the alsa-utils package to list the ALSA sound cards on the host system and select Specify host sound card again.

    For example: aplay -L

  6. Click OK to save your changes.
  • I don't see ALSA sound card in the dropdown of VM settings. doing alsa-utils on Kali returns bash: alsa-utils: command not found which is weird because it is already installed. – Halnex Dec 30 '16 at 22:54
  • And the output of aplay -l ? – GAD3R Dec 30 '16 at 22:58
  • This card 0: AudioPCI [Ensoniq AudioPCI], device 0: ES1371/1 [ES1371 DAC2/ADC] and this card 0: AudioPCI [Ensoniq AudioPCI], device 1: ES1371/2 [ES1371 DAC1] – Halnex Dec 30 '16 at 23:00
  • install oss4-base package then run dpkg-reconfigure linux-sound-base – GAD3R Dec 30 '16 at 23:13
  • Installed oss4-base but running dpkg-reconfigure linux-sound-base returns this pkg-query: package 'linux-sound-base' is not installed and no information is available and trying to install linux-sound-base returns this Package linux-sound-base is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source. However the following packages replace it: oss4-base – Halnex Dec 30 '16 at 23:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.