1

Before you mark it as a duplicated please listen to the problem. I took a lot of time searching on this issue and found very similar problems but none of them solved it because the suppose solution files simply doesn't exist.

I have two interfaces on my Fedora 22 machine, which one as a different DNS server. At the /etc/resolv.conf the first nameserver is the nameserver of my school and then comes my nameserver. I want to solve DNS queries of mydomain.com that my school domain doesn't know. On this scenario the query must be asked to my DNS server. I solved this issue on other machines by updating /etc/dhcp/dhclient.conf with supersede or prepend but at this machine this file doesn't exist. Any suggestions?

It might be worth to tell that I'm using NetworkManager service to configure those interfaces.

I found that /etc/dhcp/dhclient-eth0.conf might be what I'm looking for. Does the option supersede is acceptable here too?!

0

For Fedora :You should check on /etc/sysconfig/network-scripts/ifcfg-eth0/enp2s0. When you edited ifcfg-eth0/enp2s0 BOOTPROTO=dynamic as your dhcp client. If I am not mistaken. You mentioned dhcpclient.conf was on ubuntu/debian. Dont mess up between Ubuntu and Fedora distro.

  • I don't want to mess up with protocol – rockability Dec 30 '16 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.