2

I recently installed Qubes OS and I would like to install VLC Media Player on my personal VM which is based on Fedora 23.

To configure RPM-fusion I ran the two following commands (found on the french fedora documentation):

$ su -lc 'dnf install --nogpgcheck http://fr2.rpmfind.net/linux/rpmfusion/free/fedora/rpmfusion-free-release-stable.noarch.rpm'

$ su -lc 'dnf install --nogpgcheck http://fr2.rpmfind.net/linux/rpmfusion/nonfree/fedora/rpmfusion-nonfree-release-stable.noarch.rpm'

First I tried to configure RPM-Fusion using download1.rpmfusion.org server as said here but it's not responding.

Then I'm trying to install VLC typing

$ sudo dnf -y update
$ sudo dnf install vlc

but the VLC package is not found. I've the following error:

[user@personal ~]$ sudo dnf install vlc
Last metadata expiration check: 1:23:59 ago on Fri Dec 30 10:18:41 2016.
No package vlc available.
Error: Unable to find a match.

Is this an other way to install VLC ? I'm used to use Debian based OS and a simple sudo apt-get install vlc is enough.

Informations

[user@personal Downloads]$ dnf repolist
Last metadata expiration check: 0:00:33 ago on Fri Dec 30 14:03:49 2016.
repo id                                                                    repo name                                                                                      status
*fedora                                                                    Fedora 23 - x86_64                                                                             46,074
qubes-vm-r3.2-current                                                      Qubes OS Repository for VM (updates)                                                              186
rpmfusion-free-updates                                                     RPM Fusion for Fedora 23 - Free - Updates                                                         380
rpmfusion-nonfree-updates                                                  RPM Fusion for Fedora 23 - Nonfree - Updates                                                      106
*updates                                                                   Fedora 23 - x86_64 - Updates                                                                   21,532
12
  • Tried running dnf -y update before attempting to install vlc?
    – schaiba
    Dec 30, 2016 at 10:00
  • I tried it, but vlc package is still not found.
    – Anthony
    Dec 30, 2016 at 10:43
  • Please add the output of dnf repolist
    – schaiba
    Dec 30, 2016 at 10:51
  • I typed it, it has loaded something (an update it seems). I added the output into my question.
    – Anthony
    Dec 30, 2016 at 10:58
  • As you can see, the rpmfusion repositories weren't added for some reason, and that's why vlc is not found. I suggest you download the two .rpm files and use dnf localinstall to install them, then update and repolist again to check.
    – schaiba
    Dec 30, 2016 at 12:23

1 Answer 1

2

@schaiba found the solution, thanks.

RPM fusion was installed, but not enabled. This is the default behaviour. To enable it :

$ cd /etc/yum.repos.d/
$ sudo vim rpmfusion-free.repo

In the first section set enabled=1 if it's set at 0.

$ sudo vim rpmfusion-nonfree.repo

Again in the first section set enabled=1 if it's set at 0

Then, run an update and an install.

$ sudo dnf update
$ sudo dnf install vlc
1
  • 1
    Note that you will also want to enable the "updates" repos: rpmfusion-free-updates.repo and rpmfusion-nonfree-updates.repo otherwise you will not receive updates to packages sourced from rpmfusion Nov 11, 2019 at 23:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .