2

I'm trying to compile and install gearman onto a CentOS 6 box, and am getting an error when I compile from its source code. It requires the boost libraries, and was failing on that at first, but I installed those and it gets past that. Now, however, when I run ./configure it is failing with the message:

. . .
checking for ld that supports -Wl,-z,relro... yes
checking event.h usability... no
checking event.h presence... no
checking for event.h... no
configure: error: Unable to find libevent

So I installed libevent like so:

yum install libevent.i686

And that didn't help. So I downloaded the source to my home directory, extracted it to a sub directory within my home directory, ran ./configure and then make install and then tried ./configure on the gearman source, but it still gives me the configure: error: Unable to find libevent message. You can imagine how annoying that is! Especially after I tried installing libevent via yum and then installed it from source.

Any tips to get gearman ./configure to get past this message?

Thanks!

5

You need libevent-devel for the development files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.