5

I made an update to my arch-linux, then I tried to run virtualbox, I got this error message:

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing '/sbin/vboxconfig'  

When I tried to execute the command, I got:

/sbin/vboxconfig: No such file or directory

Also I tried modprobe vboxdrv, and got the message:

Module vboxdrv not found in directory /lib/modules/4.8.13-1-ARCH 

Any help for the problem!

  • modprobe won't work, since each time You replace kernel You need to recompile (or compile 1st time) it's driver. How about just installiing fresh virtualbox with pacman? – JustMe Dec 29 '16 at 20:24
  • More information please, what packages did you update that broke vbox? have you rebooted since the update? – sam Dec 29 '16 at 20:27
  • I update the system and install last version of kernel. – Ahmad Yousif Dec 29 '16 at 20:31
  • Yes, i rebooted after the update – Ahmad Yousif Dec 29 '16 at 20:32
  • Try sudo vboxreload. – phk Dec 29 '16 at 21:45
2

Kernel modules are installed on a per-version basis. After you upgrade to a new kernel version, you need to re-install the VirtualBox modules (and any other out-of-tree modules, such as closed-source video drivers).

-1

Suppose you have the kernel version 4.9. You will have some kernel modules installed for your specific kernel, e.g. linux49-virtualbox-host-modules. If you upgrade to kernel version 4.15, you need to go install linux415-virtualbox-host-modules.

Keep in mind, the specific drivers you might need may very. For instance, you may need linux415-virtualbox-guest-modules instead. Just check which ones you had in use before and download the corresponding versions for your new kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.