2

I am almost certain my Debian 8 computer is just detecting one video card. The computer has two video cards, specifically an Intel HD Graphics 520 (integrated) and NVIDIA GeForce 940-mx (2GB).

I think only one is being detected since when I use the command lspci -k | grep -A 2 -i "VGA" it returns

00:02.0 VGA compatible controller: Intel Corporation Device 1916 (rev 07)
Subsystem: Hewlett-Packard Company Device 820a
00:04.0 Signal processing controller: Intel Corporation Device 1903 (rev 08)

and the command lspci|grep VGA returns

00:02.0 VGA compatible controller: Intel Corporation Device 1916 (rev 07)

When I ran the above codes the NVIDIA drivers were already supposedly installed, had download them directly from their page and installed them, since the package nvidia-detect didn't detect any video card in my computer.

Is my NVIDIA card really not being detected? how can I fix this?

  • Update the database sudo update-pciids and try again with lspci .. – GAD3R Dec 29 '16 at 18:32
  • Nothing changed, only downloaded something called daily snapshot – M.O. Dec 29 '16 at 18:38
  • I will go to BIOS and check because I don't know. – M.O. Dec 29 '16 at 18:49
  • 1
    Install the nvidia-smi package and run : sudo nvidia-smi – GAD3R Dec 29 '16 at 19:04
  • 2
    You can use the terminal or via mail there is some examples and format here debian.org/Bugs/Reporting – GAD3R Dec 30 '16 at 18:56
1

You ought to be able to see the card even without a driver installed, could you try lspci | egrep 'VGA|3D|NVIDIA' -- if you still don't see it, I would ensure that the card is seated firmly and that any auxiliary power connectors are attached.

However, I suspect the problem is that you have a laptop with hybrid graphics. To support this it seems Bumblebee and primus seem to be required.

| improve this answer | |
  • I tried the command and it didnt appear, downloading Bumbleblee and primus as we speak. Not sure how I'd use it to install the video card though, but I will keep reading. – M.O. Dec 29 '16 at 19:01
  • Interesting! It seems that NVIDA or "3D" should certainly appear in LSPCI if the card is present, are you certain it's physically installed? – marpa Dec 29 '16 at 19:04
  • Yes, it is physically installed. The computer is new and when it came with Windows you could see it installed. – M.O. Dec 29 '16 at 19:57
  • could you upload/post the output of dmesg command? – jsalatas Oct 15 '19 at 0:48
  • If lspci does not show the card, that means the card is not even detecting as a generic PCI(e) device. It might be disabled by your BIOS settings: if there's a setting called something like "disable Optimus" or "use iGPU only", that might be disabling the NVIDIA GPU at the PCI(e) bus level. – telcoM Oct 15 '19 at 6:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.