1

I recently upgraded my os from Mint 17.3 to Mint 18.1. Now dual screen doesn't work. I tried to install newest fglrx drivers from http://support.amd.com/fr-fr/download but X server doesn't boot.

I tried to install AMDGPU-Pro but I simply have Unsupported OS.

Here is more information about my card :

lspci -v | grep AMD
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde XT [Radeon HD 7770/8760 / R7 250X] (prog-if 00 [VGA controller])
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]

Is there a solution? Do I have to downgrade? I only want to have dual screen and I don't care about gaming.

  • Downgrade xorg, or use the opensource driver or install windows. – Ipor Sircer Dec 29 '16 at 14:03
  • @IporSircer sorry but I need more precision. Installation of open source driver is very unclear. I found the way to downgrade Xorg for archlinux but not for mint. Please, can you give me more details? – Dougui Dec 29 '16 at 14:54
  • driver: apt-get install xserver-xorg-video-radeon downgrade x: apt-get install xserver-xorg-core=<previous version> – Ipor Sircer Dec 29 '16 at 15:08
  • @driver I tried both. Nothing changed after the installation of the open source driver. I tried to downgrade xorg but I can't find a correct version number. apt-get install xserver-xorg-core=1.19 gives "version not found". – Dougui Dec 29 '16 at 15:43
1

I had the same issue, what I did was (if I remember all):

Update Kernel to 4.9

apt-add-repository ppa:paulo-miguel-dias/mesa
apt update
apt install xserver-xorg-video-amdgpu mesa-utils
apt upgrade

for details go here

  • I finally choosed to reinstall everything and go on ubuntu 16.10. I can accept the answer because I can't test it. Thanks ! – Dougui Jan 10 '17 at 14:15
1

If you wish to install the AMDGPU-PRO driver on mint you have to make a small edit on the installation script for it to recognize mint… Open the install script that you download from the site and in line 47 replace ubuntu with linuxmint like so :

case "$ID" in
    linuxmint)

Then you should be able to install them no problem...

1

Success with mint Cinnamon 18.3 and the newest amdgpu-pro driver (17.50)! This is with a Radeon Vega Frontier Edition card, though I have reason to believe this will work with other cards if you download the correct driver. OpenGL and OpenCL work and seem to be at least as fast as Windows (which is using a slightly older driver). Have not tested Vulkan or video acceleration.

The main trick is that xorg-server must be updated to xorg 1.19 or the modules won't load due to ABI mismatch. This may require you to enable the unstable packages repository: apt install xserver-xorg-hwe-16.04

Download the driver from AMD. Go to http://support.amd.com/en-us/download and then use "manually select your driver". For me I had to choose "Professional Graphics", "Radeon Vega Frontier Edition", "Radeon Vega Frontier Edition", and "Linux", hit "Display Results". Point at the Download buttons to see what version you are getting, you want 17.50 or better for Ubuntu (note this is newer than the ones indicated by most help I could find on the web, the older ones work but they compile a kernel module and otherwise seem more complex, I believe 17.50 is the first "open source" one). You do not need the "preinstall" script. Hit the correct Download button.

Unpack (change the number to what you downloaded):

cd ~/Downloads
tar -Jxvf amdgpu-pro-17.50-511655.tar.xz
cd amdgpu-pro-17.50-511655

Fix the Ubuntu-specific script to work on Mint using some editor: nano amdgpu-pro-install. Replace ubuntu) with linuxmint), and in a new twist in 17.50, remove the ${1+"$@"} after $APT (This appears to be for sending switches given to the script to apt, but it truncates the command line instead, I don't know enough bash to figure out why, and may be a bug in Mint's apt, or a bug in this script).

Run the install script like this: ./amdgpu-pro-install --opencl=rocm It says to use legacy in place of rocm for "pre Vega10". I wasted some time trying to figure out if my card is "Vega10", AMD manages to not tell me anywhere, but I suspect it is true of anything called "Vega".

Other installation instructions said to do usermod -a -G video $LOGNAME. I don't know if it is necessary, you might want to try without it.

And then sudo reboot and enjoy!

If it screws up, look in /var/log/Xorg.0.log. Search for "amd" just to see if it is trying to find it, and then look for "unloaded" to find failed modules. If it complains about "ABI major version" then you need to change which xorg you are using. If you can't get it to work you can run amdgpu-pro-uninstall, note that for that to work you must edit then install script in-place as it copies it and runs it again to uninstall!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.