-1

Step 1: I have cloned my main diskdrive by dd cmd: bash -c "dd if=/dev/sda |pv| gzip > /media/disk/sda-backup.gz"

Step 2: Now I like to make the cone work running from USB stik. I have a 120Gb usb stick and the old hhd are 80Gb.

I then used below cmd:

gunzip -c /media/disk/sda-backup.gz |pv -pter -s 80g | dd of=/dev/sdc bs=64K

Step 3: bootup on the usb stick on another computer then the original........ here is the problem, the boot looks fine to start with choosing the Fedora (2.6.27.25-78.2.56.fc9.i686)

When booting I get the problem/error with Red Hat showing in the attached picture.

Bootup problem RedHat / physical volumes

If I boot the usb stick on the original computer then its works fine. So I assume, that I need to change somewhere(???) the boot files / location is on another location then the physical volumes...

  • It would have been FAR FAR faster to have not used dd at all, but to have run pv </dev/sda | gzip > /media/disk/sda-backup.gz – roaima Dec 29 '16 at 14:06
0

Put usb-storage module (and its all dependencies) into initrd.

  • can you explan how, I assume you mean the file initrd-2.6.27.25-78.2.56.fc9.i686.img and thats a binary file, im not sure how to add usb-storage module... – Steffen Dec 29 '16 at 10:18
0

Apparently, you have a LVM setup on the original computer where VolGroup00 contains the LogVol01 volume which is your actual root device.

The physical device where that volume group resides is probably not the origin device (/dev/sda) you copied with dd.

That's why it does not work on your other computer, only on the original one.

What you could do is copy the root files from /VolGroup00/LogVol01 (whatever that is) to your stick and change the root= kernel option to the new location, e.g. /dev/sda1.

Look at the output of sudo pvs to find out which physical device contains the VolGroup00 group.

  • modprobe dm-mod vgchange -ay then i can mount: mount /dev/VolGroup00/LogVol00 /mnt/ inside i can see the files are there. But how do I change root= kernel option? maybe that could do the trick. I assume there is somewhere that is says sda and i need to thange that to sdb (usbstick)? – Steffen Dec 29 '16 at 13:05
  • You can change the kernel options in the grub.cfg file in /boot/grub. But currently it is set to /dev/VolGroup00/LogVol01 and that device cannot be found... You could try to provide more information (disk layout, LVM setup), that would be helpful. – cbley Jan 2 '17 at 8:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.