I have a Vizio internet TV, the predecessor to this one with basically the same specs, not 3D though. I wanted to try and gain root access to the tv.

Using nmap I leaned that the only port open is 111, rpcbind. I also see that it is running Linux kernel 2.6.9 - 2.6.28.

If I run rpcinfo on it I only find two rpc servers, the tcp and udp versions of rpcbind.

It has a USB port on it, but I can't use it for anything.

Given this how could I proceed from here? Any sources of information you could refer me to that would be helpful? Or any tools that may help me out? Finally, how feasible do you think this project is?

  • 2
    You would probably have to find an available exploit for rpcbind. – n0pe Mar 3 '12 at 20:19
  • 1
    Did you also scan for for UDP ports? i.e. sudo nmap -sSUR -O – penguin359 Mar 3 '12 at 22:58
  • Yep, I tried that. On one scan nmap output that there were 300 some filtered ports, and when I did another scan to try and list them, it returned that all but the rpcbind ports were closed. It has said that ever since. I'm not sure if it was an nmap fluke or something else. – Snitse Mar 4 '12 at 16:28
  • Where could I find information about exploits for rpcbind? Googleing doesn't come up with much. – Snitse Mar 4 '12 at 17:04
  • 2
    Take it apart. Look for serial and jtag headers. – ali1234 May 3 '12 at 16:37

Have a look at xda unboxing. I understand that they prob don't cover your TV, but looking at other linux-based device unboxing will prob help you out tons. The nook one is quite interesting.


Just as @ali1234 suggested, you might have to take it apart.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.