2

I need to connect to a hidden network without password with wpa_supplicant:

iwlist <interface> scan output:

 Cell 02 - Address: 11:22:33:44:55:66
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=67/70  Signal level=-43 dBm  
                    Encryption key:on
                    ESSID:""
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=##################
                    Extra: Last beacon: 248ms ago
                    IE: Unknown: ######
                    IE: Unknown: ##################
                    IE: Unknown: #####
                    IE: Unknown: ##############
                    IE: Unknown: ######
                    IE: Unknown: ###############
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (2) : CCMP TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: ###################

What is the wpa_supplicant configuration file needed to connect to this network?


Wrong guess:

network={
    ssid=""
    bssid=11:22:33:44:55:66
 }
1

According to Wiki-Archlinux you should add scan_ssid=1 to your wpa_supplicant configuration file:

Tip: To configure a network block to a hidden wireless SSID, which by definition will not turn up in a regular scan, the option scan_ssid=1 has to be defined in the network block.

to connect to an open network, you need to add the key_mgmt=NONE option to your wpa_supplicant configuration file :

network={
        ssid=""
        bssid=11:22:33:44:55:66
        scan_ssid=1
        key_mgmt=NONE
}
  • This solution does not work for me (wrong conf file). – user123456 Dec 29 '16 at 23:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.